[rpi2] Webdav not mounting at boot

This is my first post, I hope I didn’t forget anything, otherwise let me know :smiley:

I am currently experiencing problems loading a webdav folder with davfs2

I have no problem mounting the folder, but I have trouble loading it at boot.

What you were doing when this issue occurred
I’ve tried this with another raspberry distro (musicbox) and I don’t have any trouble auto mounting.

The problem occurs every time I boot it, never made it work.
The device you are currently running OSMC on
I’m currently running OSMC on a raspberry pi 2.

What peripherals are attached to the device?
Connected are

  • a usb disk drive (Seagate)
  • a USB soundcard (soundblaster +)

Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?
It appeared ever since i first tried it.

I followed this guide http://www.sbprojects.com/projects/raspberrypi/webdav.php

Added some code to rc.local
my fstab looks like
https://flowparty.stackstorage.com/remote.php/webdav /home/osmc/stack davfs rw,noexec,_netdev,noauto,user,async,uid=osmc,gid=osmc 0 0

I’ve tried
mount -a
mount /home/osmc/stack

in \etc\rc.local

I’ve gotten this message from journalctl

Mar 11 10:59:57 osmc systemd[1]: Failed to mount /home/osmc/stack. Mar 11 10:59:57 osmc systemd[1]: Dependency failed for Remote File Systems. Mar 11 10:59:57 osmc systemd[1]: Unit home-osmc-stack.mount entered failed state.