RPi3 2017.04-2 disk image/update download

I updated to the 2017.05-2 version and the CEC stopped working properly (it turns on the TV again and again, even with the line “hdmi_ignore_cec_init=1” in config.txt. As it was working on the 2017.04-2 build, I reverted to a previous backup I made with Win32diskimager but it’s the 2017.04-1 build. Is there a way to install the subtitle fix without updating to the May release? Even if I want to reinstall from scratch there is no disk image for 2017.04-2.

Many thanks

Some help?

Is there anyone who could help? I just need to know if there will be a 2017.04-2 build disk image or if I still can upgrade to the mentioned build… @sam_nazarko?

I think you’ll be out of luck on a 2017.04-2 downloadable image.

If you revert to 2017.04-1, the subtitle vulnerability will be there, though it’s my understanding that as long as you don’t download subtitles, the exploit won’t work. (Though I’m happy to be corrected.)

Generally, Sam encourages people to raise problems, such as CEC no longer working, on the forum so that they can be fixed, otherwise you’re going to be stuck on 2017.04-1.

Thank you for your answer.
Well, I wrote on the forum for my previous (and different) problem with CEC updating from Jarvis to Krypton and I had no luck so I had to contact Logitech for a workaround on my remote (repeating inputs).
I saw that there are other people with the same (new) problem with CEC (it always turns on my amplifier and TV, it didn’t happen with april build) so I didn’t open a new ticket. I had to downgrade to 2017.04-1 because with the latest build my system was pretty unusable (it turns on the tv every 10 second) and unfortunately I didn’t make a backup of 2017.04-2 build.
I see that every month is available a disk image so I presumed that, considering that the “1” build is affected by the subtitle vulnerability, an updated (“2”) disk image would (and should) be available.
Thanks for your help

Rather than just going back to an old build it’d be better to work with us to understand the problem so that you can stay up to date AND have the desired CEC functionality.

Do you actually use CEC for controlling your Pi? If not you may be able to simply turn it off.

You are right, of course!
As I have a spare SD and all the family use the RPi I’d like to revert to a “working” build and do the tests on the spare SD (as I always did).
I actually use CEC to control my Pi so I cannot turn the functionality off.
My current setup is: RPi3 -> Pioneer HTP 071 Sintoamplifier -> Philips PFL 5605 TV.
I updated to the may release and, without changing my setup, the RPi continues to turn on TV and amplifier. I checked on the CEC configuration and all seems to be ok (even the “hdmi_ignore_cec_init=1” line on config.txt).
Beside providing logs again is there anything else I can do to address the problem?