RPi3: IR remote works, remote profile selected, Kodi not responding

Hello. I just set up an IR receiver on GPIO 18 and everything works according to mode2 -d /dev/lirc0 but I can’t get Kodi to respond. I have selected the correct profile under My OSMC → Remotes. I use xbox-lircd.

Other methods work for navigation, e.g. CEC, and even an original Xbox gamepad, but apparently not the original Xbox DVD dongle remote.

Edit: “Oh I see, the coordinates need to be…”

Joking aside, the forum maintainers might want to honor the exif rotation data or something.

How do you know it’s the correct profile?
Try irrecord to set up your own


Like this

I tried irrecord, don’t really know much about it though:

irrecord: could not find gap. irrecord: gap not found, can't continue

Your TSOP might be problematic.
mode2 means pulses are detected, but doesn’t mean that they are meaningful.

Thanks for the suggestions.

I tried irrecord with another remote, and it works after selecting the generated .conf in the UI. There seems to be no problem with the tsop.

While I can’t rule out that there’s a problem with the xbox-lircd.conf (e.g., why is there a control character after KEY_OK on my screenshot?), it does suggest that the Xbox remote operates differently from other remotes. When vewing the LED with a camera it doesn’t appear to flicker, unlike other remotes. Perhaps there are some special timing issues there.

Not experienced enough to know whether this is because of the .conf, or some hardware limitation of the tsop 34436. The remote is made for the tsop 1556.

After doing some reading I think you’re right in that the tsop is problematic.

If I understood correctly the carrier frequencies are 36 and 56 kHz respectively, which likely means the remote is not compatible with the sensor.

Thanks for helping me rule out the other possibilities.