Rpi3 new setup buffering


Having issues with constant buffering and broken playback on RPI 3 running OSMC (latest stable release). I’m trying to locally stream from an old windows 7 PC (AMD A6 3670) through Samba. I’ve setup OSMC to connect to an emby server on the windows PC, but am using Samba to retrieve the video files.

Am having stuttering issues when playing back all videos I’ve tried. For consistency I’ll stick to the one video below (which is only 720p at this stage, and if we get improvement will try another 1080p video). Am trying now over wired ethernet, but have also tried over wireless (preference for wireless). Router is an Asus AC68U, located approximately 2 metres from the Pi, the WIndows 7 PC is wired to the Router at 1gb LAN.

Have tried disabling OMXPlayer and running MMAL, have tried disabling MMAL and running OMXPlayer, both with stereo stream decoding disabled.

Audio would be pass-through mode to a soundbar compatible with DTS and AC3.

OSMC log available at: http://paste.osmc.io/ibujimoteq

Unique ID : 0 (0x0)
Complete name : Battle of the Bastards.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 2.17 GiB
Duration : 1 h 8 min
Overall bit rate : 4 553 kb/s
Encoded date : UTC 2010-02-22 21:41:29
Writing application : no_variable_data
Writing library : no_variable_data

ID : 2
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L3.2
Format settings, CABAC : Yes
Format settings, ReFrames : 2 frames
Duration : 1 h 8 min
Bit rate mode : Constant
Nominal bit rate : 4 424 kb/s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 29.970 (30000/1001) FPS
Standard : NTSC
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.160
Default : Yes
Forced : No
Color range : Limited

ID : 3
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : A_AAC
Duration : 1 h 8 min
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 44.1 kHz
Frame rate : 43.066 FPS (1024 spf)
Compression mode : Lossy
Language : English
Default : Yes
Forced : No

ID : 1
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Language : English
Default : No
Forced : No

Any help would be appreciated, I was hoping the rpi 3 would be a suitable downsize to this old AMD workhorse (which I’m using as a glorified NAS now).


Always first thing to try to know if it is a network or codec issue is to copy the file locally on to the Pi and play it from there. If problem still there than it is a codec issue, if problem gone than network need to be checked.
First step there is trying to measure raw throughput between both devices with iperf.