RPi3 no wifi found?

Just got my new RPi3, updated my sd card on the RPi2, moved the sd card over to RPi3
Boots fine, straight into kodi, but only have wired connection available in myosmc.

ifconfig reports eth0 and lo, no wifi.
iwconfig says “command not found”

No mention of wifi that I can see in dmesg.

Did you run sudo connmanctl enable wifi or enable it in My OSMC -> Network first?

It doesn’t appear in My OSMC, I only have Wired Bluetooth MySQL

osmc@osmc:~$ sudo connmanctl enable wifi
Error wifi: Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

It seems like you may not be up to date


I upgraded half an hour ago.
osmc@osmc:~$ uname -a
Linux osmc 4.4.3-3-osmc #1 SMP PREEMPT Tue Mar 1 15:51:08 UTC 2016 armv7l GNU/Linux

If you boot with Ethernet disconnected does it show up in MyOSMC GUI?

Silly question, but are you certain it is actually a Pi 3 and isn’t a mislabelled Pi 2 ?

Check the model number on the top side of the PCB. If it is the correct model, please provide debug logs using My OSMC → Log uploader.

no it doesn’t appear if the ethernet cable isn’t connected either

Yes, I have both.
It’s definitely a RPi3.

I will upload logs shortly, just going to download a clean image and reinstall on another sd card in case it’s an upgrade issue.

Ok, fixed now, a clean install solved it. Not sure what went wrong with the upgrade process though.
ifconfig correctly reports the wlan0 interface, connected fine over ssh.
wireless-tools isn’t installed by default, should it be?

Thanks for the pointers to fixing this.

Happy bunny now :wink:

I’ve been using my RPi3 for a while now on OSMC without too much of a problem. Today I was having problems accessing the device through my phone (on the same network), so decided to restart it. After the restart, I thought I’d go to My OSMC–>Network–>Wireless, but the “Wireless” and “Bluetooth” menu items were both missing. When I tried to exit, it took about a minute to come back to the regular OSMC menu.

I thought something may have gotten corrupted, and flashed a fresh, new card (chose to configure WiFi automatically), and after running through the reinstallation was asked if I’d like to manually configure my network since it couldn’t do it automatically. I still can’t see my WiFi or Bluetooth on the fresh installation. I plugged my original OSMC card back in and noticed an error on shutdown:

[FAILED] Failed to start Broadcom 43xx bluetooth HCI.
See ‘systemctl status brcm43xx.service’ for details.

I dug up a LAN cable, ssh’ed to the box and got this result:

brcm43xx.service - Broadcom 43xx bluetooth HCI
Loaded: loaded (/lib/systemd/system/brcm43xx.service; enabled)
Active: failed (Result: exit-code) since Mon 2016-05-23 19:31:15 IST; 15h ago
Process: 243 ExecStart=/usr/bin/hciattach /dev/ttyAMA0 bcm43xx 921600 noflow - (code=exited, status=1/FAILURE)

I’m thinking of sending the device back - it’s got a 6 month replacement warranty from the place I bought it - I’ve seen some people reporting issues with Bluetooth (I couldn’t find any mention of WiFi issues) after a recent update, but I’ve still got to take time out to try putting an old version on it to try.

What image for you use here?

I tried the latest build, then last months build - I got the same results though. Tried a little more troubleshooting, then gave up. I’m sending it back tomorrow.