Rpi3 - October '20 release not working

I tried to update to October release when prompted, however OSMC just told me that installing update failed. After the update attempt, OSMC was very sluggish.

I reinstalled OSMC from scratch, but it still doesn’t work. After selecting language and time zone I’m stuck on the network phase - Networking Add-on keeps on throwing exceptions.

Logs can be found here:

I’d maybe test your SD card to see if it’s still ok, could be starting to fail, they don’t last forever

The log shows that connman keeps failing to start, though the reason isn’t clear.

Assuming that you haven’t made any changes to the networking configuration that might have caused connman to fail, I’d suggest that you reinstall on a fresh SD card. If it still has problems, it could be hardware related.

I downgraded OSMC to 06/2020 version and it seems to work perfectly, so I think it’s quite unlikely that my SD card is corrupted.

I wouldn’t be so sure that the SD card is 100% ok. There might be some bad cells that you will hit on a random basis. Try upgrading or reinstalling 2020.10 and see what happens.

There are thousands of Pi3s out there running the latest version of OSMC without such a problem.