RPI3 OSMC (2020.01-2) - Error when running qBittorrent-nox

Hello guys, I’ve installed qbittorrent-nox without any issue and it works.

However, if I look at journalctl while it is running, I see a lot of messages like this:

dbus[292]: [system] Rejected send message, 3 matched rules; type=“method_call”, sender=":1.47" (uid=1001 pid=27806 comm=“qbittorrent-nox “) interface=“net.connman.Manager” member=“GetTechnologies” error name=”(unset)” requested_reply=“0” destination=“net.connman” (uid=0 pid=377 comm="/usr/sbin/connmand -n --nodnsproxy --config=/etc/c")

What could be the root cause?
Can they be ignored?

Can you point me in the right direction, please? Thank you :slight_smile:

t seems that you’re not running qbittorrent-nox under user osmc, whch has a UID of 1000.

I’d suggest that you try editing the file /etc/dbus-1/system.d/connman-dbus.conf and replicate the block of policy code for user=“osmc”,

<policy user="osmc">
    <allow own="net.connman"/>
    <allow send_destination="net.connman"/>
    <allow send_interface="net.connman.Agent"/>
    <allow send_interface="net.connman.Counter"/>
    <allow send_interface="net.connman.Notification"/>

substituting the username for UID 1001. Then reboot.

Thank you dillthedog.
I created a dedicated user to run qbittorrent-nox, because I thought it was a best practice. Now that I have copied the policy section from osmc user to the new one, as you suggested, the error message has gone and it still works :slight_smile:

However now I get a new error related to wifi “Unexpected reply signature: got “”, expected “a{sv}”” (this is happening even if I run qbittorrent-nox as osmc user, or a systemd service).

Do you know what does it refer to and what it means?


Does it happen if you revert /etc/dbus-1/system.d/connman-dbus.conf to default and run qbittorrent-nox as the osmc user?

Thanks Tom.

Hi Tom,
you are right, I was not clear enough :slight_smile:

Yes, I restored the old connman-dbus.conf, but the message is still there (at least 1 every 10 seconds).
I will only use “osmc” as qbittorrent user, for simplicity, until the issue is solved.


1 Like

Unexpected reply signature: got “”, expected “a{sv}

is a qt5 debug message

Ok… but what does it mean? Could I safely ignore it ?
And if yes, is there a way to reduce the log level ?

yes you can ignore it, hyperion.ng has the same issue and i dont know about reducing logs from it, google probly does

I will try to study more deeply.
What I found until now wasn’t helpful to disable those messages that are flooding the journal :frowning:
In the meanwhile, any further suggestions would be appreciated :wink:
Thank you again

This error was reported back in March 2018 for qbittorrent-nox: [HowTo] qBittorrent on OSMC - #46 by amnesia89 The version in Debian stretch is 3.3.7, which is rather old (latest seems to be 4.2.1). The version in Debian buster is 4.1.5, so perhaps the problem will have been fixed by then.

In your qbittorrent service file, you could choose to send all error messages to /dev/null, instead of the system journal. It will, of course, send all error messages, which might bring its own problems.

In the [Service] section you’d need to add the line:


Yes, that would finally help to suppress messages, I didn’t thought about it as a temporary workaround, thank you :slight_smile:

I will take a look at version 4.1.5.
Moreover, I can try to compile latest version from source, but as far as I can see a lot of dependencies need to be upgraded.

Indeed. I expect it will be easier in Debian buster.

I tried to compile 4.2.1 but it seems that it requires qmake >= 5.9.0, whereas stretch is on 5.7.1 (buster is on 5.11.3).