RPi3 OSMC - suddenly no signal over HDMI on the TV

All of the sudden my TV claims there is “no signal” from my OSMC Raspberry Pi 3. It was working fine yesterday. I tried plugging/unplugging the cable. I replaced the cable. I rebooted it a few times. Nothing seems to help.

RPi3 is running fine - can SSH into it etc. Everything was working fine yesterday and I didn’t touch it since then.

I can see nothing suspicious in dmesg.

Any thoughts? Could it be a hardware failure? Any way to know?

Since you can SSH I would recommend you run “grab-logs -A” and post the url it gives in this thread.

Here we go - the log from the box: https://paste.osmc.tv/ijuhabezeb

Anything interesting? I don’t see anything obvious at the moment…

I would suggest…

sudo nano /boot/config.txt

and try stock with just your ir added…


Same result, I’m afraid, no signal

I know you replaced the HDMI cable but it wouldnt surprise me the second one could be bad also

What exactly is this plugged into for a display, and how long is the cable your using? Have you tried connecting directly to a display with a hdmi cable six feet or less? Does the blue OSMC splash screen appear during boot and then you lose signal, or do you never get anything displaying at all?

An LG TV. I can find out the exact model, but it has been working just fine for over a year. With the same cable. The cable is maybe a meter long. The second one I tried is a bit shorter.

I don’t see any splash screen. The TV tells me initially “Connecting to device” and then “there is no signal”.

1 Like

I don’t need to know the model. I saw that you had hdmi signal boosted so I wanted to make sure there was not a problematic setup like being connected to a projector through a long cable. I’m at a loss here. The Pi is set to 1080p60 and talking to your TV which shows support for that output. I think I would try a different input on the TV and if that doesn’t work try another display. If there is no output in either of those two events you could try a fresh install which would fix any potential corruption in the RPi’s boot code. Since your not getting the splash screen I don’t think the issue is with OSMC or Kodi.

So the mystery is partially solved. I attached the RPi to an HDMI monitor with the same cable - and it worked! Therefore the fault is with the TV somehow after all. I guess it’s not an OSMC question anymore then. Weird though, how the TV screen most certainly works (menus, “no signal” picture), but it refuses to accept the signal from the box. I tried all 4 HDMI ports on it with no luck so far. If you guys have any smart suggestions, I’d love to hear them.

Does the tuner work and it’s just the hdmi ports that don’t work? Perhaps it is something similar to what is shown in this video…

Well, I don’t have any other source of videos - no antenna or cables, so can’t really check. But I’ll give this idea with a dryer a try, thanks.

Just to be clear I was posting that video as a possibility of what was going on and not to recommend his temporary fix. Someone can literally kill themselves playing with a TV that is plugged in like that. When you have issues with solder failure of SMT components the best your going to do with a hairdryer is get it working for a very brief period of time. All your actually accomplishing is getting a small amount of movement because of thermal expansion. This does not have enough heat to melt the solder and without flux it would never properly rebond anyway.

To whom it may concern:

I am having the exact same problem. However I thought one of my nephews may have broke my RPi3 accidentally, so I discarded it and got a RPi4, however, SAME ISSUE. So now my TV is not receiving the signal from either the RPi3 or the RPi4. And now I am the no closer to finding out why. If it is my TV, than that just sucks, but if this is becoming a notably larger issue, I would like to know so that I can get to fixing the problem so my family can enjoy our movies and TV shows again.


I’m not exactly sure what you want us to say in response to that. TV’s, just like all electronics only last so long. Sometimes you will have a total failure, but other times you may have just a certain part of the set stop working. The only real solution here is to plug in a known working device to test, or take your device that is not working and plug it into a known working display. As far as “becoming a notable larger issue” i’m not sure what that means. If you google the make and model of your TV you might find some common failure which may or may not have a viable solution for repair.

In any event this is well outside of the scope of this forum. We don’t have anything to do with TV repair and OSMC doesn’t currently run on the RPi 4.

My apologies. My temper about the situation (losing out traditional form of viewing movies) may have blasted the problem larger than it actually is.

My comment “becoming a notably larger issue” is merely referencing the fact I have now come across an LG, a Vizio, and Samsung TVs all reporting the same type of error while attempting to utilize a RPi3 (or in my case RPi4). Again, I apologize for losing my temper with my typing earlier. I am just getting frustrated on how to fix this for my family and I haven’t seen many solutions that hold for any extended period. Thank you for taking the time to respond to me.


First thing I would try is does it work with Raspbian? If it does, then come back here, with prints of the config.txt from each distro.

Yeah, I tried, but it did’t work. The TV is 10 years old actually. Ended up buying a new one :slight_smile: