RPi3 running hot

Since the July update my RPi3 has been running a bit hot comparatively. I run OSMC along with pi-hole. Both my July and Aug updates failed with an error regarding unable to install an unknown package but “My OSMC” page indicated the version as the latest.

And my Pi which usually runs at 45 - 50 degree C is hovering around 65 - 72 degree C recently and this temperature spike happen even when Kodi is idle. However the temperature spike isn’t constant and a restart of the mediacenter (not the Pi) brings the temperature back to the 45 -50 range. There is also situations where the memory spikes to 70 to 80% however the temp & memory spike aren’t at the same time.

I am not sure what logs to attach since the general instruction is to attach kodi logs after a restart, but my temp spike goes off after a restart.

I am attaching the APT Logs logs for now, Please let me know if there are any other particular details I can provide to troubleshoot this issue better.

Your upgrade error comes from the package that you installed asking questions during upgrading. As you have so many non standard packages installed I suggest you do upgrades via command line instead of MyOSMC.
Configuration file '/etc/rpimonitor/template/network.conf' ==> Modified (by you or by a script) since installation. ==> Package distributor has shipped an updated version. ==> Keeping old config file as default. [....] Restarting rpimonitor (via systemctl): rpimonitor.service[?25l[?1c7[1G[[32m ok [39;49m8[?25h[?0c. Processing triggers for libc-bin (2.19-18+deb8u10) ...

Thanks for the reply. How do I update osmc through command line? BTW what are those non standard packages? Is it because of the other stuff I have installed?

I have pi-hole, rpimonitor, vnc server & a failed vpn install (which I uninstalled).

And any pointer on the heat issue?

sudo apt-get update
sudo apt-get dist-upgrade

Was the app that was asking a question during upgrade

Nope maybe also caused by one of the many packages installed or other issues. Without a debug log it is hard to guess.

In the past I’ve also stumbled with higher PI tempearatures with osmc.
I will describe it - maybe it will be helpful:

I have my PI with a hdd connected trough USB - everything in the same box.
The hdd is configured to auto standby by default.
But that is only true if the disk is properly mounted.
In my case, there was a power failure and the disk became with the “dirty flag” set - As a consequence, the system weren’t able to mount the disk and activate the standby

(/etc/udisks-glue.conf)

A disk running for hours will force higher temperatures inside the box and in the Pi itself.

In my case it was easily solved by forcing a fix in the filesystem (I’m using NTFS) and rebooting:

ntfsfix /dev/sda1
ntfsfix -d /dev/sda1
reboot

(some 30 minutes after reboot, the hdd should be in standby mode and the Pi temperature much lower - in my case it decreased from 70C to 50C) - but that also depends on the box and the room temperature.

Hu? Unless you are powering the drive via tha Pi. the drive spinning vs sleeping will have no difference on the CPU temp. If you are powering the drive from the Pi, I’d suggest using a powered hub instead.

EDIT: I missed that you have the drive in the same case. That’s nothing like the OPs issue.

Might be a n00b question, but does this update OSMC along with other stuff on the Pi (like packages from other installs) or just OSMC only?

Well actually there was no prompt when I kicked off the update from “My OSMC” in Kodi[quote=“fzinken, post:4, topic:38326”]
Without a debug log it is hard to guess.
[/quote]

Happy to get you those if I know how to get them :stuck_out_tongue_winking_eye:

Thanks for the pointer mate, but my RPi3 is sitting ‘naked’ on a open table below the TV, so it has plenty of ventilation :slight_smile:

1 Like

This will do the same as the update via MyOSMC (means updating all packages other than kodi addons)

Surely there was no prompt. MyOSMC is designed to not disturb people therefore all prompts will be handled automatically. But if packages (like the one you installed) don’t react as designed errors will be shown

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

ok, so you meant the kodi debug logs. To be fair I did go through this link earlier and as I mentioned in my original post since the instructions said reboot kodi I didn’t get the debug log. In my case when the Pi or Kodi is rebooted the high temp goes away. However I will update the debug logs shortly (when the temp spikes up again).

Again appreciate all your help mate :slight_smile:

Not only the Kodi logs but all logs can be uploaded thru MyOSMC or command line grab-logs -A

Well I did upload my grab-logs -A logs in my original post. Anyway here is the logs directly from Kodi captured as instructed in the wiki. After reboot the Pi started with a temp ~ 60C and I managed to get it upto ~70C by searching stuff on an add-on before uploading the logs.

After uploading the logs I stopped the mediacenter and the temp went down to ~48C

Guess one of your addons being the culprit. So only way is to start clean and test one addon added at a time