RPi4 (DeskPi Pro) could not mount bootfs


Thank you for the endless hours of hard work on this project.

Attempting to install from a USB stick.

Booting from the stick works but from there the installer runs and only returns:

Install failed: could not mount bootfs

Internally the DeskPi Pro has a daughter board mating with the RPi4. It extends both HDMI ports; GPIO; Type-C power and even the TRRS port to make them available at the back of a NUC-style case. At the front the boards adds a power button; two more USB2 ports and a MicroSD card socket that is connected to the Pi’s own. Lastly, there is a secondary board with a SATA interface that is hooked into the RPi by a USB3 double adaptor. This can serve a traditional 2.5" SSD or an M.2 stick via a third adaptor board.

I write all that not to advertise the product but try and explain the situation.

Would be great if I could just use the USB stick as traditional installation medium and set up OSMC on the 2.5" SSD I have connected.

Is this a feasible installation scenario?

Noticed some people have encountered the same error with earlier generation RPi units. At least once fixing the problem by using a different MicroSD card.

In this case, I have no MicroSD card and was hoping to avoid using one with the 2.5" SSD being the primary media.

Any constructive help would be greatly appreciated :slight_smile:

Only installing/booting from SD Card is currently supported by OSMC

You still need an SD card for booting the OS.

I managed to get OSMC going on my Pi 4 with Argon ONE M.2 case. This case has an M.2 SATA to USB adapter built in, and may be similar enough to your setup. My end result is OSMC botting from the M.2 SATA drive (connected by USB), and no SD card present. I’ll refer to the M.2 SATA drive as the USB drive from now on…

Here’s roughly what I did:

  1. Do a normal install of OSMC to SD card.
  2. Manually partition the USB drive using parted, creating a fat32 boot partition and the remaining space as ext4.
  3. Copy the files over from the SD card installation to the new partitions.
  4. Update the partition references in the target /boot/cmdline.txt and /etc/fstab.
  5. Power off and remove the SD card.
  6. Boot.
1 Like

I did the same this morning, but I used rpi-clone instead of parted, link: here

I found that much easier than using parted and then copy the files over. When rpi-clone was done I just mounted the both partitions and changed /boot/cmdline.txt and /etc/fstab. Then rebooted and it worked like a charm :smiley: