Rpi4 - KODI freezes, kernel crashes few minutes after playing video

Hello again.
I did fresh and the possible cleanest OSMC install (latest release 2021.11-2).
The only thing that I changed after installing was adding one video source via Kodi internal SMB location.
I’m on 1Gb Ethernet.

Few minutes after plaing the video freezes and I get this in logs:

2021-12-21 15:44:15.415 T:652     ERROR <general>: ffmpeg[0x5aa03b0X]: [h264_v4l2m2m] === poll unexpected TIMEOUT: events=0x147, cap buffers=18
2021-12-21 15:44:20.831 T:653      INFO <general>: Skipped 1 duplicate messages..
2021-12-21 15:44:20.831 T:653      INFO <general>: CVideoPlayerAudio::Process - stream stalled
2021-12-21 15:44:20.833 T:649     DEBUG <general>: CVideoPlayer::HandlePlaySpeed - audio stream stalled, triggering re-sync
2021-12-21 15:44:20.833 T:649     DEBUG <general>: CVideoPlayer::FlushBuffers - flushing buffers
2021-12-21 15:44:20.856 T:653     DEBUG <general>: CDVDAudio::Flush - flush audio stream
2021-12-21 15:44:20.856 T:653     DEBUG <general>: CDVDAudio::Pause - pausing audio stream
2021-12-21 15:44:21.834 T:649     DEBUG <general>: CDVDMsgGeneralSynchronize - global timeout
2021-12-21 15:44:21.834 T:653     DEBUG <general>: Skipped 1 duplicate messages..

full logs here (grab-logs -A):
https://paste.osmc.tv/asubificat

As You can see there is also kernel crash when this problem occurs.

I am observing this behaviour in previous OSMC also. I changed SD card, power supply and even HDMI cable, but still no luck.

I think the problem is only when I play videos with eac3 audio format, but I’m not sure.

This video file is causing problems:
http://paste.osmc.tv/hikexiduji.vhdl

But this played fine (from beginig to the end):
http://paste.osmc.tv/esikipuxam.mel

I’ve also tested the same hardware configuration with Libreelec 10.0.1 and for a day that I was playing with it all worked fine (the same files played fine). So maybe it is not somehow hardware related.
I’d stay with LE but I like OSMC more (eg. the packaging system) :slight_smile:

EDIT:
I have passive alu case - the temperature does not exceed 50 degrees. (celcious)

Any ideas?
Thans and best regards.

1 Like

Try playing the file from local storage

I’ve just tried to play from local SD.
Unfortunately after about 10 minutes the same situation occurs.
New logs here: https://paste.osmc.tv/qemeqejeze
(generated with “grab-logs -p -G -v -k -r -s -f -O -a -J -i -d -K -m -D -b -n -X” ← this because -A hanged on all vcgencmd commands and didn’t end.)

One update - I was trying to ensure this is only OSMC related, but when I was checking lately once again on Libreelec - the same thing happened.
And also - only with eac3 codec, played from network or local storage.

So… this is not only on OSMC. May it be Kodi? May it be faulted hardware? - but if so, why this only happens playing with this particular codec?

Same problem here.
Stream stalled.
On quite many videos.
265 videos works best.

Should this “bug” be reported on github or are the developers already aware of it?

If the problem is reproducible on LibreELEC as well as OSMC, it’s an upstream issue for RPi guys to fix. They are working regularly on improvements, so I am sure things will improve over time.

1 Like