[RPI4] Mode2 using "code" instead of pulses and spaces unable to make gpio-ir work, irrecord was used to make file

hello I am trying to get my remote for using GPIO-ir/lirc(I don’t know the difference). I am running into the issue of my mode2 using “code” instead of spaces and pulses then I tried using sudo mode2 -r -d /dev/lirc0 but I got a different error (see below). I was able to run irrecord and it seemed to be doing something but upon trying my remote it did nothing. I did download an older config for the same remote (RC66) but it was made for kodi when kodi was still called XBMC in the folders name… truthfully I would love to use the rc66 pre made config, the buttons make sense and I believe I have the same remote as on directv the guide for programing a remote is rc66 not rc66x. but I am not sure why it is not working my IR was pulled from a dvd player (it has a metal shield) but I am unsure what type it is.

older config for same remote (rc66)

my rc66x .conf for lirc

my config.txt

osmc@osmc:~$ sudo mode2 -d /dev/lirc0                                           Using driver devinput on device /dev/lirc0
Trying device: /dev/lirc0
Using device: /dev/lirc0
Running as regular user osmc
code: 0xffffff00495d5d0035170001a3040000
code: 0xd5040001720400008402000121020000
code: 0x8102000123020000d404000122020000
code: 0x80020001240200008102000176040000
Partial read 8 bytes on /dev/lirc0osmc@osmc:~$ ^C
osmc@osmc:~$ sudo mode2 -r -d /dev/lirc0
Using raw access on device /dev/lirc0
Using device: /dev/input/event0
Running as regular user osmc
Could not get code length: Inappropriate ioctl for device

What remote are you using?


I am using a directv rc66x remote https://www.amazon.com/DIRECTV-Rc66X-Remote-Control-Programmable/dp/B00I4L2TXS

hey sam sorry I forgot to reply to you directly my bad. It is a directv rc66x it seems to make the .conf file but osmc does not respond to the buttons pressed Idk if I am missing a step or not, did I send the required things as welll?

I had some problems in getting IR to work - different from yours. But in the very beginning I had to disable eventlircd. Otherwise all button events are “silently” forwarded towards lircd/kodi.


systemctl stop eventlircd

to stop that daemon (and start to re-start). And now the standard IR commands should “see” IR events.

Regards, Michael