Rpi4 with latest OSMC and 5Ghz only 70mbit


Can anyone tell me why my rpi4 with 8gb RAM and installed OSMC has a soooo slow Wlan Connection? It‘s connected to 5Ghz and I have only 70mbit max. and 200mbit Upload. Other devices have much more than 200mbit Upload, some of them 300-450mbit.

It could be a limitation of the device and the internal antenna.

You could compare speed in Raspberry Pi OS to rule out a software issue and consider using an external dongle.

I have tried it with Speedtest-cli and the result is:
54mbit/s download and 50mbit/s upload.

Suggest to try in your LAN with iperf3 (see below) instead of speedtest-cli but generally the Pi4 Wireless might not support MIMO / spatial streams.

Edit: yeah seems only single stream

I think I know what is the problem:-)

Instead using wifi6/ac or ax my rpi has wifi4/n.
I read that changing the countrycode to „BO“ will fix this issue.

As I’m using OSMC on my rpi4 I do not have anymore the raspi-config to change wifi settings or the country code. When I go into the osmc menue → rpi menue there i See only very few config options.

I know that the country code can be changed in the wpa supplicant file but in my directory there is no such file?!? Why?? Shal I just create it manually??? I have connected my device over the osmc wifi menue just for your information.

You can set country with crda
Install crda sudo apt-get install crda.
Add your 2 digit country ISO code into /etc/default/crda REGDOMAIN sudo nano /etc/default/crda
Then reboot. After reboot check with iw reg get if it is set correctly

But I doubt that is your problem

Already done that but my regdomain I have set is not active. I use BO as I know that only that is working to get wifi ac running.

Any suggestions why I am not connected to wifi ac???

Any ideas what i have to do to get wifi6/ac running???


What speeds do you get on RapberryPI OS?

Thanks Tom.

I will install now the rpi os and check if I can use wifi6/ac. But still I’m wondering why the region is not set after I have installed crda

1 Like

I came across this topic when searching after having troubles with buffering network streams. I only then also realised that although when connected to the 5 GHz band the router was announcing Wi-Fi 4 with lower speed. Following the instructions you gave for installing crda and setting REGDOMAIN worked for me (did not even have to use BO, the actual country code did it). My Raspberry Pi 4 is now listed as Wi-Fi 5 when connected to the 5 GHz band with corresponding higher speed, and streaming without buffering is working again.

So maybe setting a country code is necessary to overcome limitations of the default settings, or is it just coincidence?

Anyhow, thanks a lot for helping me with this older topic!