Rpi4 won't boot after Nov update

OK, so when the latest update came out, i installed it through the normal process, when it was done it wouldn’t boot. I would get the OSMC logo and then no signal.

I run a very basic setup.
Was too hard to troubleshoot, formatted the SD card and reinstalled OSMC.
Very quickly i got another update prompt. I decided to leave it just incase.

I just ran that update and had the exact same thing happen.

Reflashed my SD card with the newer image (11-2) and now that won’t boot.

It went through the automated config part but afterwards it still wont boot.

As far as i can see by looking at my DHCP Server, it doesn’t boot enough to ask for an IP address so i can’t remote in to get logs.

I only have the Power, ethernet, HDMI and a USB reciever for a wireless keyboard plugged in.
Have tried with all of those (except power) removed and it still does the same thing.

Not really sure what else to do.

Just flashed it with the old image again and it booted without issues

You’re not giving us much to go on.

Had a look through that again

Please clearly explain the problem

In your report, please let us know:

  • The issue you are currently experiencing with OSMC

It won’t boot. I get the OSMC splash screen and then a blank screen. The Pi seems to hard lock.

  • What you were doing when this issue occurred

Updating to the latest version (using the automatic update feature and flashing the new version directly to an SD card)

  • Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.

By updating to the latest version and turning on the Pi.

  • The device you are currently running OSMC on

Raspberry Pi 4

  • What peripherals are attached to the device?

Wireless Keyboard Receiver

  • Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?

Yes, the November update.

After opening My OSMC , navigate to Logs . Using this method will result in a URL link that you should provide so that others may be able to view.

Can’t boot so no way to open My OSMC and navigate to Logs

Logs can also be uploaded via the command line and result in a URL you can provide for support by running the following command:

The pi does not boot. No way to enter the command.

Sanitizing your logs

can’t sanitize what you can’t get

By posting a Kodi screenshot in your support question, it may help diagnose the problem.

i can give you a photo of my blank TV screen, but i don’t expect that will help much.

Now, if there is a way too get useful logs off a Pi that won’t boot or any other information that might be helpful, please let me know.

Understood. What display are you using and are you going through an AVR? Only some users with Pioneer AVRs and 4k TVs have reported problems.

Do you mean the blue screen, or do you only see ‘Please stand by’? If you get the blue screen it may be booting enough to get an ethernet connection (but not wifi) for you to use ssh to get logs.

Otherwise, if you can upload debug logs after booting from the reinstall image we’ll get a better idea of your setup.

[quote=“grahamh, post:5, topic:91665, full:true”]
Understood. What display are you using and are you going through an AVR? Only some users with Pioneer AVRs and 4k TVs have reported problems.[/quote]

I was using my Onkyo AV Receiver, but have just plugged it straight into my TV and had the same results.
I have an LG 4K TV.

When going through my Receiver i get a solid blue screen, connected directly to my TV i get nice photos thrown up on the screen, which is what it does when you switch to an input with no signal.

I use Ethernet, not wifi.

I put this in my config-user.txt file but it didn’t help


Have tried both HDMI Ports with and without those settings.

The Pi also gets super hot at that point. I left it for a few minutes just incase it needed more time. The metal surround of the USB ports is uncomfortably hot to touch.

I am using a Samsung 64Gb SD Card at the moment. When i did the test install earlier, i did it on a Sandisk SD Card so i can swap them. The Samsung is what I’ve been using for months so i don’t think it’s that.

I’ll put the Sandisk in again and get the logs from the working install, but as i said above, my setup is very simple. I have a wireless keyboard and i play media off a SMB share. No special addons installed, etc.

OK, thanks. It doesn’t sound like the thing we’ve been working on with Pioneers. I think it needs someone who knows more about RPi4 than I do.

Ok, am very confused now.

On a hunch, i decided to try a different power supply.
Rebooted and it actually fully booted with the new version.
I was able to complete the setup, add my file share and played some media. Yay!
rebooted the Pi using the menu. It hung while booting like before.
Manually rebooted. It fully booted again.
I turned on the debug logging, rebooted and was able to upload the logs.


Not sure if anyone can tell anything from that.

I understand the Pi’s need decent power supplies, it just seems odd i can literally have 2 SD cards with different versions of OSMC on it and one will work and one won’t all because of the power supply.
I’m still a little worried that it hung once with the ‘new’ power supply.

Newer versions of OSMC and Kodi have increasing resource requirements, and power supplies degrade over time. It’s likely that your older PSU is borderline and will be problematic (i.e. not even boot on the older version of OSMC soon).

TBH i was actually using one of the always on charging ports of a computer to power it. Was convenient and seemed to work at the time.
It hung again when booting, looks like i need to do some research into what is a good adapter… or maybe just buy the genuine one.


That stopped being viable after Pi 2 – when power requirements increased. I was guilty of the same – but mainly only did so for quick testing. After Pi 2, I found ths impossible.

Same problem here. Pi4. Fresh install with november release. After initial install screen everything goes black.
PSU is 3A 24W. So should be enough.

Went back to august release and could even run it from my USB-hub…

That’s an interesting power rating. It should still be taking 5V, so 15W @ 3A. Thats what the official power adapter is.
I do know that supplies that support quick charge will bump up the voltage, it’s possible it’s not supplying enough power at 5V?
Otherwise, i know the actual cable can be part of it as well, so might not be terrible to swap that out too.

1 Like