RSTP stream causes sadface after November update

When starting an RTSP stream to watch my Surveillance camera live stream, it instantly causes a sadface.

This worked before the update, I know this as it is a function that I uses almost every day.

Just to be sure, i made a complete reinstall of OSMC to just to be sure that nothing else could cause this.

Full debug logs are Here
The logs are a paste of the original logs, where I have removed the credentials for the RTSP stream, as the log uploader failed to do that automatically.

Thank you :slight_smile:

EDIT: The stream plays fine in VLC

Hi,

I’ve received another report from a user about this, so will investigate.

Can you confirm if disabling hardware video acceleration solves the problem?

Sam

Hi.

It still crashes with hardware video acceleration disabled.

:slight_smile:

OK – the issue is likely ffmpeg related then.
I will try and reproduce.

1 Like

same here, all my rtsp streams result in sad face after the latest update…

Hello Community,

since the Kodi-Update i cant show TV Programms anymore wit PVR Simple Client 3.8.6.
I have configured PVR Simple Client to receive the url from my SAT/IP Receiver like this:
Sample M3u

After i installed the new Update i cant show TV anymore, when iam click on the TV Icon, Kodi crashed with the sad smiley,
then restart the mediacenter. Here is a complete Log with more Info:
Extended Kodi Log

Any Tips whats went wrong are very helpful.

@Runlevel3, I moved your post here as it is also an RTSP stream you have issues with.

Still working on this

Sam

Hi Sam.
Let me know, if you need help testing some changes. I don’t mind reinstalling or anything else.

Thank you.

Maybe this helps out for the bug fixing:

https://github.com/xbmc/FFmpeg/commit/6b…947d49e9a3

It part of this kodi ffmpeg release: https://github.com/xbmc/FFmpeg/releases/…-Leia-18.4

1 Like

We are already using latest ffmpeg
You could try update to staging which reverts ffmpeg for now and see if that helps.

Tried updating to staging, as i could see you made some changes on Github a couple a days ago, but no luck, still crashing :frowning: