RT5370 Issues, at wits end

Hello community!

So I’ve scoured the OSMC forums, the intert (I’d like to think I have the google-fu) and I can’t get the answer to my question.

I purchased an RT5370 chipset niceEshop Mini 150M USB WiFi Wireless LAN 802.11 n/g/b Adapter with Antenna (http://www.amazon.com/gp/product/B008IZQCGK?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00) - because… 7 bucks. one of my OSMC machines sits out in our sun porch which is separated by 90% brick wall and 10% sliding door. With the sliding door open, alls well - except my cooling bill. So I opted for a dongle with an antenna input. Got it in the mail, and alas no luck.

I have tried the following:
using conman to detect and connect. Conman doesn’t find the USB wireless device.

Downloading and attempting to install the driver (http://www.mediatek.com/en/downloads/rt8070-rt3070-rt3370-rt3572-rt5370-rt5372-rt5572-usb-usb/) but I ran into too many issues attempting to sudo make (I even hopped on with root, got the source files from https://osmc.tv/help/wiki/kernel-sources and attempted all I could to get it to compile, but there are many limitations that I just didn’t have the patience to get around after 5 hours of very poor linux experience)

Does anyone have a sure-fire way to get this Ralink RT5370 chipset working with OSMC? Anyone have experience setting things up that could give a step by step? Are there coming updates to OSMC that will provide support for this chipset? Any info would be much appreciated.

Hi

I believe this device is already supported. Can you check if it is detected by running dmesg and posting here?

Sam

Edit: Removing giant wall of text.

http://paste.osmc.io/rurufuloqi

I wish you would do dmesg | paste-log and just give us the link.

My apologies. Again, only basic experience with any linux-based OS. Wasn’t aware this is an option.

The log I gave you above COULD be a bit convoluted as it was from a fairly busted instance of my OSMC install. I’ve just started fresh again, so that I can get everything set up from scratch, and did a dmesg paste. The link is http://paste.osmc.io/rurufuloqi

my RT5370 dongle works perfectly with no additional drivers.
And i have to say it works also very well (much better than a r8188eu dongle)

The RT5370 driver is already in OSMC and does seem to work well. (I have one adaptor using this driver and whilst not super fast as it is a cheap adaptor it does seem reliable)

The problem comes about when some vendor releases yet-another-model ™ of adaptor that uses the same basic chipset but has a different USB device identifier. (Vid/Pid as shown in dmesg)

The driver is usually capable of supporting the adaptor but doesn’t have the Vid/Pid in its list of supported adaptors thus the kernel doesn’t know to use that driver for that adaptor. (Every driver has a list of USB vid/pid’s that it supports)

Typically this can be fixed by patching the Vid/Pid of the adaptor into the drivers list but that means a kernel/driver rebuild to implement it - unless you’re really handy with compiling linux kernels it’s something we would need to do.

So to add support for adaptors that are not detected we need to know the Vid/Pid of the adaptor from dmesg and know for sure which driver supports this adaptor and we can theoretically add support for it in the next kernel update.