RTL8192CU driver unable to host AP?

Hey,

could it be that the RTL8192CU driver is unable to host an AP?
I’m getting the following error message when tryting to do so:

root@osmc:/# hostapd -d -B /etc/hostapd/hostapd.conf
random: Trying to read entropy from /dev/random
Configuration file: /etc/hostapd/hostapd.conf
drv->ifindex=3
l2_sock_recv==l2_sock_xmit=0x0x12c2648
ioctl[SIOCSIWMODE]: Invalid argument
Could not set interface to mode(3)!
Could not set interface to master mode!
rtl871xdrv driver initialization failed.
root@osmc:/#

Wifi is up, wlan0 has an IP address etc… bascially hostapd is the only thing thats missing, but it can’t get into mode(3).

On a side note: i think there should be more information in the FAQ/wiki about stuff like compiling kernel modules/drivers yourself, or information on systemd (i was very confused at first when switching from raspbmc to osmc, when my upstart scripts did nothing…). Other than that OSMC likes great already, keep up the good work!

nobody any info on that? that chipset is so common, i can’t be the only one having tried it…

“iw list” does show AP in supported modes, and i was able to host an AP with the exact same wifi dongle on an raspbmc pi 1 b…

edit: sorry, maybe i should mention that it’s the RC version on a RPi2 :wink:

i’m a bit frustrated here, the exact same setup worked in raspbmc on my pi 1 b, yet it does not work in osmc on my pi 2…

root@osmc:/home/osmc# iwconfig wlan0 mode master
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.

maybe this one helps?

also this:

root@osmc:/home/osmc# iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        RTS threshold: 2347
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports RSN-IBSS.
        Supported Ciphers:
                * WEP40 (00-0f-ac:1)
                * WEP104 (00-0f-ac:5)
                * TKIP (00-0f-ac:2)
                * CCMP (00-0f-ac:4)
                * CMAC (00-0f-ac:6)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 1:
                Capabilities: 0x1862
                        HT20/HT40
                        Static SM Power Save
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT TX/RX MCS rate indexes supported: 0-7, 32
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps
                        * 5.5 Mbps
                        * 11.0 Mbps
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * start_ap
                 * new_station
                 * new_mpath
                 * set_mesh_config
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * join_mesh
                 * remain_on_channel
                 * set_tx_bitrate_mask
                 * frame
                 * frame_wait_cancel
                 * set_wiphy_netns
                 * set_channel
                 * set_wds_peer
                 * probe_client
                 * set_noack_map
                 * register_beacons
                 * start_p2p_device
                 * set_mcast_rate
                 * Unknown command (104)
                 * connect
                 * disconnect
        Supported TX frame types:
                 * IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
        Supported RX frame types:
                 * IBSS: 0x40 0xb0 0xc0 0xd0
                 * managed: 0x40 0xd0
                 * AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
                 * AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
                 * mesh point: 0xb0 0xc0 0xd0
                 * P2P-client: 0x40 0xd0
                 * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
                 * P2P-device: 0x40 0xd0
        software interface modes (can always be added):
                 * AP/VLAN
                 * monitor
        interface combinations are not supported
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Device supports TX status socket option.
        Device supports HT-IBSS.
        Device supports SAE with AUTHENTICATE command
        Device supports low priority scan.
        Device supports scan flush.
        Device supports AP scan.
        Device supports per-vif TX power setting
        Driver supports a userspace MPM

anything, anyone?

Any news on this?! I’m using the latest OSMC Build on a Pi B, getting the same error.
Works on Raspbmc. I found a interesting link: http://www.jenssegers.be/blog/43/Realtek-RTL8188-based-access-point-on-Raspberry-Pi

the latest comment says: > I suspect the kernel (3.18.7+) includes an updated driver that screwed the pooch.

That could be a reason… Anyone knows how to replace the driver?!

regards

did not really make any realy progress… i did replace the drivers with some modified realtek drivers (basically the ones you can download from their website modified so that you can compile them for the new kernels), with which i was able to actually run hostapd (i also compiled several versions of hostapd, no success with any of the versions 0.8, 2.0 and i think 2.4 or whatever the newest at the time was) and actually SEE the AP with other devices, but i was unable to connect to it.
Also tried a different (same model) dongle and another one with the RTL8188something chipset, same problem. Pretty sure this has to do with the RTL8192CU as opposed to the 8192CU drivers… but since i wasn’t able to get it running even with 8192CU (although this way i can at least see the AP), there might be more to this than JUST the drivers.

thank you for the reply cr4wler. I’m using a 8188CUS Device, would it be possible to tell me how you compiled the Realtek drives, I downloaded these Drivers and manily how to add them to hostapd, I would try it myself with the 8818.
Did you follow the included guides?

regards

a lot has changed since these drivers where written, you’ll be unable to compile them…

you can try these:

(i think those were the ones i used, might have been others though… if you run into more compile errors, it might have been a different one… i can say for sure after the weekend)
(edit: might have been these: GitHub - pvaret/rtl8192cu-fixes: Realtek 8192 chipset driver, ported to kernel 3.11.)

but you might have to edit the makefile, i ran into problems because of a new gcc version (add “-Wno-error=date-time” to CFLAGS), there might have been something else too, but i think they compiled with only very little modification (can’t remember exactly anymore).

if you run into problems, i can help some more, but i will be pretty busy until after this weekend and can’t guarantee that i can come back to you in a timely manner.

again though: i WAS able to compile the drivers and run hostapd without errors (or only insignificant ones), but couldn’t connect to the AP afterwards. if you manage to get it running, tell me how :slight_smile:

thank you i will try a few things, really annoing… no need to get it done before the weekend :wink:

regards

hi guys, any news on that!? I’am able to start the AP, configuration testing runns fine, but I’m not able to connect to the AP, same problem as @cr4wler mentioned…

would be great if we could find a solution…

regards

havent tried further… will probably wait for another RC or the release itself to try again

Any news??

nope, but i have to admit, didnt try newer versions… but since you’re asking, i guess the problem persists :smile:
which version did you try?

Realtek drivers don’t properly support this. It doesn’t look like this is going to change in the future I’m afraid.

Sam

That suck’s

I managed to get an AP working but I cant ping osmc I can ping my PC from my smartphone when both are connected to the PI AP.

I want this for a car project so i can use the remote control and dlna stuff.

I also tried with an Edimax ew-7811un with the same results.
What about this?
http://raspberry-at-home.com/hotspot-wifi-access-point/
And this:
http://www.daveconroy.com/turn-your-raspberry-pi-into-a-wifi-hotspot-with-edimax-nano-usb-ew-7811un-rtl8188cus-chipset/

???

Can you recommend a new card?

Thank you!!

Hi @adamericson

I used the first link Hotspot – WiFi Access Point | Raspberry-at-home.com – Your ultimate source of Raspberry Pi tutorials (WiFi, 3G, XBMC, Subtitles, VoD, TVN Player, IPLA, TVP, Squeezeslave, Logitech Media Server, Sickbeard, Webcam, Torrent, DLNA) its work’s great.

I compile a 4.1.y kernel with pvaret driver repo on RPi B+ rev2

I hope this help you.

Hey,
If only I had time my friend… Almost an year past… I’m a Tank driver in the army now (1.9 years to go) …
Glad it helped you, and thank you for the kind replay.