Sad Face after December update after installing LXDE via APT


I installed the new update but it appears to have failed, my screen goes off for about 5 seconds then on for about 10 seconds with the sad face over and over. I tried starting it over but didn’t work. I still have SSH access, is there a log I can upload?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

grab-logs -A via SSH will help

You seemed to have installed an X11 desktop environment, which isn’t supported.

/usr/bin/apt-get-real -y install lxde-core xserver-xorg xinit fbi gconf-service libgconf-2-4 libnspr4 libnspr4-0d libnss3 libnss3-1d libxss1 libnss3 xdg-utils

I suspect this is why EGL fails to draw a window, as it tries to do so with MESA.



Start-Date: 2017-11-02  18:28:56
Commandline: /usr/bin/apt-get-real -y install lxde-core xserver-xorg xinit fbi gconf-service libgconf-2-4 libnspr4 libnspr4-0d libnss3 libnss3-1d libxss1 libnss3 xdg-utils
Install: libdatrie1:armhf (0.2.8-1, automatic), gconf-service:armhf (3.2.6-3), libfm-gtk-data:armhf (1.2.3-1, automatic), libx11-xcb1:armhf (1.6.2-3, automatic), xserver-xorg-input-synaptics:armhf (1.8.1-1, automatic), libsm6:armhf (1.2.2-1+b1, automatic), libgdk-pixbuf2.0-0:armhf (2.31.1-2+deb8u6, automatic), libxkbfile1:armhf (1.0.8-1, automatic), libjasper1:armhf (1.900.1-debian1-2.4+deb8u3, automatic), libxss1:armhf (1.2.2-1), lxsession:armhf (0.5.1-2, automatic), lxpanel-data:armhf (0.7.2-1, automatic), ghostscript:armhf (9.06~dfsg-2+deb8u6, automatic), libcroco3:armhf (0.6.8-3+b1, automatic), libdrm-freedreno1:armhf (2.4.58-2, automatic), libfm-gtk4:armhf (1.2.3-1, automatic), libxcb-render0:armhf (1.10-3+b1, automatic), libxcb-glx0:armhf (1.10-3+b1, automatic), xkb-data:armhf (2.12-1, automatic), libxrender1:armhf (0.9.8-1+b1, automatic), libx11-data:armhf (1.6.2-3, automatic), libglapi-mesa:armhf (10.3.2-1+deb8u1, automatic), libcupsimage2:armhf (1.7.5-11+deb8u1, automatic), libatk1.0-data:armhf (2.14.0-1, automatic), xinit:armhf (1.3.4-1), libxcb-xfixes0:armhf (1.10-3+b1, automatic), libxcb-shape0:armhf (1.10-3+b1, automatic), libijs-0.35:armhf (0.35-10, automatic), libexif12:armhf (0.6.21-2, automatic), libxt6:armhf (1.1.4-1+b1, automatic), libwayland-client0:armhf (1.6.0-2, automatic), keyboard-configuration:armhf (1.123, automatic), libmenu-cache-bin:armhf (1.0.0-1, automatic), libxcomposite1:armhf (0.4.4-1, automatic), libcupsfilters1:armhf (1.0.61-5+deb8u3, automatic), libxxf86vm1:armhf (1.1.3-1+b1, automatic), libgtk2.0-0:armhf (2.24.25-3+deb8u2, automatic), libnss3:armhf (3.26-1+debu8u3), libpixman-1-0:armhf (0.32.6-3, automatic), xserver-xorg-core:armhf (1.16.4-1+deb8u2, automatic), libegl1-mesa:armhf (10.3.2-1+deb8u1, automatic), libxmu6:armhf (1.1.2-1, automatic), libfm-modules:armhf (1.2.3-1, automatic), fontconfig:armhf (2.11.0-6.3+deb8u1, automatic), libxcb-shm0:armhf (1.10-3+b1, automatic), lxde-core:armhf (6), libgbm1:armhf (10.3.2-1+deb8u1, automatic), xserver-xorg-video-r128:armhf (6.9.2-1+b2, automatic), libxinerama1:armhf (1.1.3-1+b1, automatic), libxmuu1:armhf (1.1.2-1, automatic), libxcb-dri3-0:armhf (1.10-3+b1, automatic), libjbig2dec0:armhf (0.13-4~deb8u2, automatic), libpangoft2-1.0-0:armhf (1.36.8-3, automatic), librsvg2-2:armhf (2.40.5-1+deb8u2, automatic), libdrm-radeon1:armhf (2.4.58-2, automatic), libxfont1:armhf (1.5.1-1+deb8u1, automatic), libxdmcp6:armhf (1.1.1-1+b1, automatic), xserver-common:armhf (1.16.4-1+deb8u2, automatic), libgtk2.0-common:armhf (2.24.25-3+deb8u2, automatic), lxde-common:armhf (0.99.0-1), libelf1:armhf (0.159-4.2, automatic), libfm-data:armhf (1.2.3-1, automatic), gsfonts:armhf (8.11+urwcyr1.0.7~pre44-4.2, automatic), libx11-6:armhf (1.6.2-3, automatic), lxpanel:armhf (0.7.2-1), libxrandr2:armhf (1.4.2-1+b1, automatic), x11-common:armhf (7.7+7, automatic), xserver-xorg-video-modesetting:armhf (0.9.0-2, automatic), libstartup-notification0:armhf (0.12-4, automatic), libobrender29:armhf (3.5.2-8+deb8u1, automatic), libdrm2:armhf (2.4.58-2, automatic), xserver-xorg-video-nouveau:armhf (1.0.11-1, automatic), libobt2:armhf (3.5.2-8+deb8u1, automatic), libxcb-dri2-0:armhf (1.10-3+b1, automatic), libwnck22:armhf (2.30.7-2, automatic), libgs9:armhf (9.06~dfsg-2+deb8u6, automatic), libxpm4:armhf (3.5.12-0+deb8u1, automatic), libpango-1.0-0:armhf (1.36.8-3, automatic), libxcb-sync1:armhf (1.10-3+b1, automatic), libxfixes3:armhf (5.0.1-2+b2, automatic), libdrm-nouveau2:armhf (2.4.58-2, automatic), libepoxy0:armhf (1.2-1, automatic), libevdev2:armhf (1.3+dfsg-1, automatic), libid3tag0:armhf (0.15.1b-11, automatic), libfm4:armhf (1.2.3-1, automatic), libwnck-common:armhf (2.30.7-2, automatic), libxext6:armhf (1.3.3-1, automatic), xserver-xorg-video-mach64:armhf (6.9.4-2, automatic), libcurl3-gnutls:armhf (7.38.0-4+deb8u7, automatic), libxft2:armhf (2.3.2-1, automatic), libgs9-common:armhf (9.06~dfsg-2+deb8u6, automatic), libxau6:armhf (1.0.8-1, automatic), libxcb-util0:armhf (0.3.8-3, automatic), libthai-data:armhf (0.1.21-1, automatic), xserver-xorg-input-all:armhf (7.7+7, automatic), libfm-extra4:armhf (1.2.3-1, automatic), desktop-file-utils:armhf (0.22-1), libxaw7:armhf (1.0.12-2+b1, automatic), libwayland-server0:armhf (1.6.0-2, automatic), libnss3-1d:armhf (3.26-1+debu8u3), libgdk-pixbuf2.0-common:armhf (2.31.1-2+deb8u6, automatic), libmenu-cache3:armhf (1.0.0-1, automatic), xserver-xorg-video-fbdev:armhf (0.4.4-1+b2, automatic), libice6:armhf (1.0.9-1+b1, automatic), x11-xkb-utils:armhf (7.7+1, automatic), shared-mime-info:armhf (1.3-1, automatic), libxcb-present0:armhf (1.10-3+b1, automatic), libpciaccess0:armhf (0.13.2-3+b1, automatic), xserver-xorg-video-all:armhf (7.7+7, automatic), fbi:armhf (2.09-1+b1), lsb-release:armhf (4.1+Debian13+nmu1, automatic), poppler-data:armhf (0.4.7-1, automatic), libiw30:armhf (30~pre9-8, automatic), libxshmfence1:armhf (1.1-4, automatic), xserver-xorg-video-radeon:armhf (7.5.0-1, automatic), libllvm3.5:armhf (3.5-10, automatic), libpangocairo-1.0-0:armhf (1.36.8-3, automatic), libnspr4-0d:armhf (4.12-1+debu8u1), xserver-xorg-input-evdev:armhf (2.9.0-2, automatic), libxdamage1:armhf (1.1.4-2+b1, automatic), libxcursor1:armhf (1.1.14-1+b1, automatic), xserver-xorg-video-vesa:armhf (2.3.3-1+b3, automatic), libatk1.0-0:armhf (2.14.0-1, automatic), libgconf-2-4:armhf (3.2.6-3), libxres1:armhf (1.0.7-1+b1, automatic), libnspr4:armhf (4.12-1+debu8u1), openbox:armhf (3.5.2-8+deb8u1), libxtst6:armhf (1.2.2-1+b1, automatic), libmtdev1:armhf (1.1.5-1, automatic), xserver-xorg:armhf (7.7+7), libxcb1:armhf (1.10-3+b1, automatic), lxmenu-data:armhf (0.1.4-1, automatic), xserver-xorg-video-ati:armhf (7.5.0-1, automatic), libpaper1:armhf (1.1.24+nmu4, automatic), pcmanfm:armhf (1.2.3-1.1), libpangoxft-1.0-0:armhf (1.36.8-3, automatic), xauth:armhf (1.0.9-1, automatic), gconf2-common:armhf (3.2.6-3, automatic), libcairo2:armhf (1.14.0-2.1+deb8u2, automatic), libthai0:armhf (0.1.21-1, automatic), libimlib2:armhf (1.4.6-2+deb8u2, automatic), libfontenc1:armhf (1.1.2-1+b2, automatic), libxi6:armhf (1.7.4-1+b2, automatic), libgl1-mesa-glx:armhf (10.3.2-1+deb8u1, automatic), xdg-utils:armhf (1.1.0~rc1+git20111210-7.4)
End-Date: 2017-11-02  18:30:05

Looks like you installed LXDE.

That will work, but it will set MESA as default libEGL.
You need to fix symlinks or work around that.

We don’t support a desktop environment at this time.


hmm, some dumb script trying to get android to run so I could install netflix, didn’t even work.

do you know where this symlink is? I will gladly remove anything that isn’t supported.

You can run Netflix without a web browser using a Kodi v18 build on Vero 4K.

I would just rip all MESA packages.


would rather just revert if that’s possible.

Unless you have a backup no revert option. So removing all the packages that LXDE pulled in is the best to do (check apt log)

okay I have removed everything and even removed a link that was in the script
“sudo ln /usr/splash.png /etc/alternatives/desktop-background”, I just moved the link.

still no joy though, @sam_nazarko, you mentioned a link, is there another one I need to fix?


sudo dpkg -l | grep mesa

and remove all packages that are returned


I would try purging the packages you installed, then running an autoremove:

sudo apt-get purge lxde-core xserver-xorg xinit fbi gconf-service libgconf-2-4 libnspr4 libnspr4-0d libnss3 libnss3-1d libxss1 libnss3 xdg-utils
sudo apt-get autoremove

I believe it still works.

it might still work, @sam_nazarko which symlink do I change to boot into osmc?

I had been running a full LXDE environment with access via xrdp (for about 2 years). This gave me the best of all worlds until the stretch upgrade which broke Kodi but otherwise still had a functioning system (mainly meaning a fully functional TVHeadend server for remote viewing & recording).

I can see that removing “mesa” apps will lead to removing almost all of the desktop environment I had slowly built over time. A full re-install now seems the best thing to do although I will try hacking out all the mesa stuff & see where it ends up. Is there an X desktop environment that is compatible with the latest Kodi ? I realise this is not a priority but any tip that may stop me going down a dead-end is appreciated.

alright I’ve tried removing everything, and no word on what link I need to change, anybody got the best way to reset the 4k?

Just a heads-up on attempting to remove LXDE (ie mesa stuff). I ended up removing everything (or so I thought) but kodi still broken so have done a full re-install of OSMC 2017.12. Last full install was mid-2015 so given I have a reasonable amount of desktop environment tinkering (ie LibreOffice, gnumeric, gimp, you name it & I have tried it & all worked). Even a full web development environment - apache, php, mariadb. No major problems.

So I now have it all going again but NO X environment or desktop window manager. And yes, my web development environment works fine. Am happy to leave it like this until there is some feedback suggesting I can progress and not break it again.

First step would be to install a simple X app (for display remotely) which supposedly requires : libx11-6, libx11-data, libxau6, libxcb1, libxdmcp6

Any idea if that would break anything ?