Sad face after trying to install update that was blocked by dependencies

Hi there, I’m new to this forum, so forgive me for any greenhorn mistakes…

After hours of trying to install the latest update that was originally denied due to several dependencies, I got at some point (having worked with

sudo umount /boot
sudo fsck.hfsplus -f /dev/sda1
sudo mount -o force,rw /dev/sda1 /boot


sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot)

the error message “atv mismatching nvidia kernel” and now I’m stuck on the sad smiley face.

I would really appreciate any help…

Since it didn’t work to upload a textfile containing a copy of the terminal commands I used, I’m also interested in the question as to how I can share that piece of information with you? Best…

We only recommend updating via My OSMC on AppleTV.
If you update to the staging repository (search) it will resolve the mismatched driver
This update will be officially released on Sunday.

Right now I don’t know how to enter OSMC again and update via My OSMC (what I usually do). Does the release on Sunday mean that I just need to run the commands mentioned above after Sunday and then it should work fine again?


Okay, thanks.

1 Like

Nvidia driver mismatch.

I have the same problem an nothing suggested in this forum works, not even the new release.

I am running LXDE GUI on top of OSMC and it works grate.

The wrong Nvidia driver was installed when I tried to install Google Earth from the Synaptic manager.

I have Nvidia G72M, Geforce go 7300.

I have installed OSMC Sun Jan 22 22.05 2017 version.

I can log into terminal and reach almost everything.

But I don’t know how to start OSMC from there if possible without driver.

I have an Apple TV1 with BCM 970015 HD graphics card.
I have a 256 GB SSD.

The only driver that works is: 304.131 and the downloaded driver that not work is: 304.134

The log says that the new driver ignore the graphic card.

So, how do I delete the new driver and install the old driver.

The old driver does not show up at wiki or Nvidia support, it is not supported any longer.

Xorg.0.log does not give any more valuable info.

Please advise.

Sten T. Martin

My logfiels are placed in:

Sten T. Martin

Update fully. The new kernel has an updated module for NVIDIA.

It seems like you have not fully updated your system. Make sure your /boot is RW

Ran the commands mentioned above again today and everything works fine again…

Same nvidia-version issue on my ATV1, just did the update again when I saw that today’s update fixed it for Henry.B . Logs are uploaded here.

This means that you didn’t shut down your Apple TV properly.
So userland updates, but kernel cannot get written to /boot, hence the driver mismatch.

You are right, another reboot apparently solved it - though I have no idea what did I wrong for the first time.

I have tried to upgrade the new release again using the commands above but with the same negative result.

I have the following error messages:

  • Unable to connect to X server: connection refused
  • Server error
  • Fatal server error: no screens found
    Faild to start 389 directory server

And what do you mean by full installation?

Since I tried to get this working fore a week with no positive result it seems to be easier to reinstall the total system?

Please advise.

Sten T. Martin

You would need to post full logs.

Where did you get those error messages from? They certainly shouldn’t be visible starting OSMC.

I would advise a reinstallation if you have made modifications to your system. Also search for how to update when your boot partition is read only. This has been covered extensively.