Sad Face after update [rebuilt now ok]

So the vero 4k just ran an update, and after this update, anything that i click on i get a sad face, and then the screen looks exactly how it does after it boots up.

i am not familiar with linux and not really sure what to do here. i got to the login screen and was going to try to reinstall using the commands

sudo apt-get update
sudo apt-get install --reinstall rbp2-mediacenter-osmc

what should i be using for the vero 4k to replace the “rbp2” in the line?

or what else should i try?


First provide logs files with grab-logs -A (share the URL) than we can advice next steps

The package for the Vero4k is called vero3-mediacenter-osmc but I first would let us take a look at the logs files

thanks fzinken, i’ll grab a log when i get home


Nothing really stands out as being the cause of your problem but I think a reinstall of vero3-mediacenter-osmc is the first step.

sudo apt-get update
sudo apt-get install --reinstall vero3-mediacenter-osmc

If that doesn’t work, try:

sudo systemctl stop mediacenter
mv /home/osmc/.kodi /home/osmc/kodi.backup
sudo systemctl start mediacenter

This will lose all your configuration settings but, if it works, will show us where the problem is.

ok tried the reinstall, after running those lines, osmc wouldn’t even run. it starts booting with the osmc symbol, then switches to the sad face on a loop.

ran your next 3 lines, and it did the same thing. ran the logs


This might be progress:

Jan 14 12:10:06 osmc mediacenter[413]: /usr/lib/kodi/kodi.bin: /lib/arm-linux-gnueabihf/ no version information available (required by /usr/lib/kodi/kodi.bin)

Probably worth reinstalling:

sudo apt-get install --reinstall libdbus-1-3

ok tried that, still same result

also at which point should i just do a complete rebuild? or is that what the reinstall vero3 statement has done? since i’ve lost my configuration files already

I think it’s time for a full system reinstall. The reinstall of vero3-mediacenter-osmc only reinstalled Kodi.

I noticed (more) evidence of a filesystem corruption:

====================== APT history.log =================== B8sj7DO8
Binary file /var/log/apt/history.log matches

---------------------- APT history.log END --------------- B8sj7DO8

That file should be readable text, not binary.

All your configuration files should still be in /home/osmc/kodi.backup, so copy them off onto a USB drive before reinstalling.

ok so i’ve done a reinstallation, and everything works now. thanks everyone for helping