Sad face after updating, not sure how to get logs?

Hey guys … I believe I ran an update for OSMC a few days ago – the same update that’s worked successfully multiple times – and then I stopped using the thing for a couple days. When I went back to the proper input on my TV to use it today, there was nothing on the screen. After checking all connections, it was unresponsive so I removed power, plugged it back in and got a sad face screen that kept resetting. I’m not sure where to go from here.

The sticky says to enable debugging for logs, but I can’t get back into it to actually do that so I’m not sure where to go from here. I am a huge noob so please be specific (for instance, people talk about doing terminal stuff and I don’t even know how to get there).


Try the manual update recovery by holding ctrl-shift while booting.

At first I was worried because I use a wireless keyboard that it wouldn’t work, but it took me to a screen. Then I realized it wasn’t recognizing my wireless internet adapter, so I had to switch to wired. Restarted again and held shit+crtl and now I’m sitting at a blue screen that says “Updating the list of available OSMC packages …” but has been here for about five minutes now. Would that be done by now or am I supposed to wait longer?

Thanks for the reply.

It can be a little time consuming on Pi, particularly B model. Give it about 30 min.

Did it ever boot back to Kodi?

It did not, unfortunately. I am still looking at that same screen.

What screen?

When you reboot, what do you see, can you take a photo?

  • Can you login via SSH?
  • Failing that, can you ping the device?


Hi – currently, I see “OSMC Update – Updating the list of available OSMC packages …” and on the bottom left it says that I successfully set time using the HTTP query, started LSB, NTP daemon, reached the target multi-user system and the target graphical interface.

I am still at that screen. From that screen, I believe I can access SSH via my PC with Putty. This is my first time using the program, but I did go into my router to find the IP address being used by OSMC. I entered osmc as my user and password and now see osmc@osmc:~$

Whatever I’d need to do now, I’m all ears. Should I reboot and see if I can do it when the device is showing the screen with just a frown face on it? When I turn it on, I get all the bootup stuff on the left side scrolling, a couple things come up and say failed before it then brings up the frown face.

I’m not sure what pinging the device is, but I do appear to have SSH access. Thanks

Try running

sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot

and report what happens.

Do all of this in one line, right? I did that, says 0% [Working] – just wait some more?

If it’s not moving from 0% then you have no network connection. I thought you said you plugged in a network cable?

Yeah, I definitely did. The port back there has lights, it knows it is connected. Previously, before I connected the ethernet cable, it was returning an error saying there was no connection (when I had my wireless adapter in) so I know that error message at least appears with my current setup.

My actual device itself is still sitting at Updating the list of available OSMC packages … Should I maybe restart, not run the auto-update, and then try to do the SSH stuff?

Can you pastebin the output of of

ifconfig && ping -c 4

Paste the output to and report the resulting url after clicking the save button?

Is this what you’re looking for?

Exactly! :smile:
Though, all this looks good. My only suspicion is heavy traffic on the update servers… At this point, I can only suggest wait an hour or two and try the update/upgrade commands again or possibly attempt a full re-install :confused:

does ping -c 4 return similar results to the google attempt before?

Yeah, similar results (no errors/packet loss). Well … I don’t terribly mind reinstalling this, as I primarily just watch things on my external drive and don’t spend too much time setting up any kind of preferences or building a library that I will lose by doing this.

Unless you have any other suggestions (I tried getting out of that update screen and trying the SSH commands above for updating and they also stuck at 0%), I’ll go ahead and do that. I appreciate all the help and at least now I’m a bit more knowledgeable on how to get in via SSH and run commands for the next time something breaks on its own or I accidentally burn everything to the ground.

If you aren’t in a huge hurry, you could

sudo journalctl | paste-log
paste-log /var/log/apt/term.log
paste-log /var/log/apt/history.log

And provide the URLs so me and the devs can take a look in the morning? Or at least have a chance to see what the issue was that created the problem, in hopes of preventing it for others in the future.

Sorry I can’t be of more help tonight!

The first thing returned an error. “mktemp: failed to create file via template ‘/tmp/tmp.XXXXXXXXXX’: Read-only file system
-bash: $tmp: ambiguous redirect”

Second link returns this

Third link returns this

That’s for your guys’ info … unless you see anything glaring immediately there, I probably will just reinstall tonight.

Did you try the new Pi SD card driver perchance?