Sad face, boot loop after upgrade attempt Vero 4k+

Hello everyone,

I tried upgrading my Vero 4k+ today through MyOSMC but after the reboot I kept getting a sad face and eventually a reboot.

I SSH’d into the vero to update it manually and got this error:

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 armv7-network-osmc : Depends: armv7-bluezalsa-osmc but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So naturally I tried “sudo apt --fix-broken install” next but unfortunately I got this message:

dpkg: error processing archive /var/cache/apt/archives/armv7-bluezalsa-osmc_3.1.0-2_armhf.deb (--unpack):
 trying to overwrite '/etc/dbus-1/system.d/bluealsa.conf', which is also in package armv7-bluez-alsa-osmc 1.0.5
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

All help will be appreciated.


I fixed it by doing:

sudo dpkg -r armv7-bluez-alsa-app-osmc
sudo dpkg -r armv7-bluez-alsa-osmc
sudo apt-get install armv7-bluezalsa-osmc
1 Like

Just quoting so we can tick as solved

I had exactly the same problem/error message. Thank you for working out the fix and posting it!!

I have a sad face loop on mine as well and can’t ssh into the box. Its complaining about the conman service on the screen. How should I proceed?