Sad face crash screen when accessing the on screen keyboard

Hey guys, I’ve been running OSMC on my Raspberry Pi ever since OSMC was first released, and over all it’s been a fantastic media center. So, for that, thank you @sam_nazarko and the rest of the OSMC team of volunteers for all of your hard work, you guys are the best.

I haven’t experienced this before, nor have I been able to find anyone else that has. So I’m hopping you can help me resolve this, cause I’m at a loss. I’m running the stable, up to date, version of OSMC (as far as I know). The only big thing that’s “experimental,” or unstable if you will, which could be the cause of my problems, I think, is the recent install of RetroPie alongside the OSMC install. This is all running using Raspberry Pi 3. I’m connected to the internet via Ethernet cord, and actually with WI-Fi as well, I think. I realize that I should probably be using only one at a time but I just keep forgetting to switch the WI-Fi off. I do have a decent amount of flash drives plugged in, most of them are 3.0, and the OSMC root file system (and the RetroPie file system) install is located on a SanDisk 3.0 128Gb USB flash drive. All of my media is located on a separate flash drive. I use a wireless keyboard from CanaKit Model CK-KB-101. Currently using the Hybrid stable skin, it’s also the skin that I’ve been using for quite sometime now, even before any of this started. I’m not overclocked at all, just using the stock Raspberry Pi 3 clock configurations. The MPG2 and WVC1 codecs have been enabled. I’ve actually recently reinstalled OSMC and started from scratch except for my library, and any other media I may have collected over time. So, I’m not sure if I had installed any add-ons that weren’t there before I reinstalled, don’t think I have, in fact I reinstalled fresh in order to get rid of a lot of extra addons that I wasn’t using. I can probably stand to get a better power supply, but I don’t think that’s the issue here since this Pi runs a lot more power hungry things without any huge problems, at least not enough to crash Kodi.

So, my problem is EVERY time that I try to access the on screen keyboard, if it be via the file manager adding a source, or searching for something on YouTube, or any other addon, OSMC crashes and gives me the sad face screen of death… From what I’ve experienced it’s quite literally EVERY single time the on screen keyboard is meant to pop up, without fail, and never a second before. When I do it through the file manager, adding a source. I can click on the “Add Source” button and bring up the Add Source prompt, but once I click the address to type it in it, it crashes. I can browse just fine for the folder I need, but if I need to type something I’m out of luck. Also, if I recall correctly, the 10 key keyboard will actually pop up no problems, and I can use that, so it’s just the main, full keyboard that’s causing the issue. I don’t have this problem while using the RetroPie part of my install only during my using Kodi.

Here are my Logs as requested, that I pulled using the OSMC directions.

Let me know what you need me to do to solve this. I’d really like to not have to do a fresh install if I don’t have to. If possible I’d really love to keep the RetroPie installed alongside it, as well, since I’m just starting to get it to run properly, and have finally been able to enjoy me some N64 Zelda action, for the first time in a very very long time…

Thank you so much in advance for all your help,

Update: I actually just tried pulling up the keyboard through the Confluence skin, and it worked no problem… So does this make it a Hybrid skin issue rather than an OSMC issue? Should I be contacting the developer of Hybrid? Or, maybe you guys can still help, and suggest something, like I can try uninstalling the skin and reinstalling it. Should I? If that’s the case how do I remove it completely to be able to reinstall it. Because every single time I try to uninstall something and reinstall it, I don’t get a fresh start as I should… I’m sure it’s a Linux thing I’m just not sure how to go about dealing with it. I’ve been using Linux for about a year now and not full time, so I’m still learning. Thanks again.

Are these flash drives all plugged directly into the Pi? Or via a powered USB hub? And the keyboard that you mentioned?

Do you have usb_max_current=1 set in you /boot/config.txt?

It may be that you are close to the limits using the Confluence skin and the Hybrid skin is using more CPU, putting you over the limit making the Pi unstable.

I do have the usb_current=1 set in the config.txt. The flash drives are plugged directly in to the Pi. I’ve used a powered USB hub before, and I also have a small 3 way USB splitter/hub that’s not powered that I’ve used before, and as long as I don’t load it up with 3 flash drives it’s never had an issue.

I can also unplug the flash drives and leave just the necessary flash drive with the file system installed on it, and it will still do the same without fail.

I’ve thought about that too, but would pulling up the on screen keyboard really use THAT much CPU? Wouldn’t streaming media, loading up addons, etc. use more CPU than just launching they visual keyboard? Because that’s literally the only time that it crashes. I don’t know, my thinking could be way off here… The other thing that I was thinking was the fact that it’s worked before on my previous install on this Raspberry Pi 3, with a LOT more “junk” installed on it. It’s also worked before on Raspberry Pi 2, and even on a Raspberry Pi B+ some time ago.

Are you sure that skin.hybrid is properly Jarvis compatible ?

If accessing the keyboard crashes on that Skin but works fine on others then yes it is a skin issue and I would contact the skin author.

Either it has not been updated to be properly compatible with Jarvis, or it has bugs.

No, I’m not sure. Actually, I feel like it maybe listed compatible up to Helix at most. Again, the only thing is it’s worked before on Jarvis and it wasn’t but a week ago or so that it worked. So I guess I’m just having a hard time understanding why it stopped working… when I first made this post I didn’t realize that it was a skin issue… So yeah I’ll contact the skin developer as soon as I try uninstalling and reinstalling the skin first, just in case something happened during the installation of it.

Thank you guys for your help though, I appreciate it.

A number of skins broke during the Kodi 16.0 (initial Jarvis release) to 16.1 update not long ago, there were a lot of posts about this on the forum, I think the Arctic Zephr skin was the main one having problems - which was actually causing a sad face loop when Kodi tried to start up.

So something did change in Kodi recently that has some bearing on skins.

I see, fair enough. Thank you for the info, good to know, maybe I’ll just start looking in to a new skin to use anyway. Since it seems like even if I get this going again, it won’t be long before it is out of commission completely. Also, thanks again for the hard work with osmc, can’t imagine my life without it anymore!