Sad face loop after krypton 17.1 update


I have been happily using osmc since 2 years ago on a Rpi3.
sometimes when I manually update I have issues until I make it run properly, I may have a special config or maybe some plugins that it does not like much.

anyway, I updated yesterday and I keep having the sad face loop.
I have tried reinstalling the packages that it listed as upgraded/installed yesterday in /var/log/dpkg.log, with no luck.
I have tried moving my /home/xxx/.kodi folder elsewhere, with no luck.
I have been lurking the forums for some extra uncovered knowledge that could help me, but I can no longer find anything that may help me, sad face.

the logs are in

could anyone give me an idea on how to fix it?

thank you guys!

First always provide full logs with grab-logs -A
Secondly you have run apt-get upgrade in the past which might have put your system in an unstable state.
Suggest a clean new install

NEVER use apt-get upgrade. Only use apt-get dist-upgrade.

Thank you for your answers guys.

I think I did a ‘grab-logs -a’, not sure if results are the same as in ‘-A’.

Concerning -upgrade, it will only tell​ me i have to do -dist-upgrade instead, so even if I missed that, system forced me to do it correctly.

And about the clean install… I am avoiding it! I customised it a little bit, I would rather prefer investigating a little bit more than having to redo all the
My installs, configs and such.

I will do a grab-logs -A’ asap.

Ok so I got the logs at

Let me know if you find something that I missed.