Sad face loop, kodi exits with code 139


I’m running relatively fresh (10 days old) installation of OSMC on rbp2. It was working well until recently. Today when I turned my tv on I was greeted by sad face loop. My logs are here: I’ve tried removing .kodi folder but it didn’t produce any results. I’ve also tried reinstalling rbp2-mediacenter-osmc but it didn’t help. As far as I can see the frowny face is caused by kodi exiting with 139 error code (see logs). There were no changes to the system done since it was working. Any ideas? Thanks

Can you post another debug log with the .kodi folder renamed (without all the 3rd party addons installed)

Sure, here:

The first set of logs you posted contained a very clear error when kodi was trying to write to the database.

Error: database or disk is full

Can you also please post the output of the command:

df -h

Here it is:

osmc@osmc-Cuddlesworth:~$ sudo df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        362M     0  362M   0% /dev
tmpfs           367M  5.1M  362M   2% /run
/dev/mmcblk0p2  7.0G  1.3G  5.3G  20% /
tmpfs           367M     0  367M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           367M     0  367M   0% /sys/fs/cgroup
/dev/mmcblk0p1  240M   21M  219M   9% /boot
/dev/sda1       459G  363G   73G  84% /mnt/hdd
tmpfs            74M     0   74M   0% /run/user/1000

There are no full partitions there so the space error is likely to have related to a corrupt database which should no longer be a problem as you have removed the old .kodi directory.

Has kodi created a new .kodi directory since you removed it?

The logs indicate you’ve done a lot of re-installing, when did the sad face loop start? Was it before, after or during the operations of reinstalling several important packages?

No, it hasn’t created new .kodi dir. The reinstalling was done after the problem occured.

Then, unless anyone else has an idea, I’d suggest that you have some other file system corruption.

Do you have access to a linux machine? If you do, insert the sdcard using an sdcard reader, run df to check which device it is (probably sdb if you only have one hard drive) then run the following changing sdb to the appropriate letters:

sudo umount /dev/sdb1
sudo umount /dev/sdb2
sudo fsck -fvp -C0 /dev/sdb1
sudo fsck -fvp -C0 /dev/sdb2

This will perform a full file system check on both parts of the sdcard and should automatically correct any errors. You can then try and reboot from the card.

You may need to run each of the last two commands several times until they return no errors. If this doesn’t work or fsck fails to remove the corruption you will need to reinstall.

Can you enable debug logs and post the log again. The second log you posted doesn’t have debug logging.

Also post your system journal

sudo journalctl | paste-log

If you have a spare SD card it wouldn’t hurt in trying that. Might be a corrupt card.

How do I change log level in OSMC? There is no GRUB so where do I add loglevel= setting? Here is the system journal: Before installing system about 10 days ago I run full write/read test on the card and no problems were found.

If you are unable to set it in the OSMC due to the crashes then you can create a advancedsettings.xml file with the debug option.

Ok, thanks. Created .kodi/userdata/advancedsettings.xml with log level set to 3. There are no other files/folders in .kodi. Here are the logs with debug enabled:

Managed to solve the problem. I ran:

~$ sudo debsums --changed

Then I reinstalled packages from which it marked files as having been changed: libvorbisenc2:armhf and mediacenter-skin-osmc. After reboot it works.

Big thanks to everyone who tried to help!