Sad face loop on reboot


#1

Hi, hoping someone can help a female pensioner with simple terminology with OSMC on Raspberry Pi 2B. Had problems out of the blue this morning when after rebooting RPi with OSMC 17.6 installed it went ito a loop of trying to restart followed by sad face. I have since done a clean install 3 times using the OSMC installer on 3 separate 12G SD cards, the last one being a brand new one. Installation and set up progress without problems but all result in the same sad face loop after a reboot. I have managed to follow instructions and SSH into the system and produce a log file using grab-logs -A which you will find here:

https://paste.osmc.tv/sojuzugoqi

Can anyone advise me please … my techy skills are not brilliant. Thank you


#2

How are you powering the Pi?
Any USB drives etc attached to the Pi?

When you reinstall the SD card, you will be prompted if you’d like to re-download the OS. I’d suggest you select Yes, in case the current download is corrupted.

Sam


#3

Hi Sam. I am connected directly to the power using the recommended plug bought fom the OSMC shop. Only one usb in use for wifi dongle for remote control. Not sure what you mean by “reinstalling the SD card” - I have taken it out of its socket in the RPi and put it back in more than once but never get a prompt. OSMC starts up but as soon as the main menu loads the sad face appears then the menu tries to liad again briefly until sad face appears again. Never get past this loop. Is it a hardware problem?


#4

Ah – now I understand.
You may need to re-install OSMC from osmc.tv/download.

Most likely the loop is caused by a problematic add-on. Via SSH, you could try:

mv ~/.kodi ~/.kodi-backup

Sam


#5

Sam, this is actually the third re-install from osmv.tv/download (reformatted cards in the the first attempst but new card for the last one) - all of which performed the same. The first two I restored settings from a backup, including my GUI settings which needed a reboot to take effect. The annoying sad face loop commenced immediately on reboot and also on subsequent tries at resitting the SD card and restarting. With my third reinstall I decided not to use the backup and manually adjusted all my settings, including changing the interface to Confluence (same as on my back up). I added downloaded just one addon. All well at this point. Then I rebooted. Could it be anything to do with the common denominator Confluence?

Sorry to be so uninformed but what does mv -/.kodi -.kodi-backup do?

Wendy


#6

If a restore of a backup is giving you problems then that does indeed suggest a problem with your Kodi environment.

The command moves your Kodi userdata away temporarily. If Kodi then starts, a bad addon is likely causing the crash

Sam


#7

Thank you. I will try that command and see what happens tomorrow but as there is only one addon (other than Confluence and Yahoo) downloaded my myself, I am at the moment failing to see why that should cause the problem … but I will try

Wendy


#8

I can see from the logs that Kodi runs for about 9 seconds before crashing meaning it’s probably something skin related.
The only really unusual thing I can see is the skin zoom being set to -4. Perhaps this is causing an overflow error.
You could try renaming the guisettings.xml file so default settings load and see if that helps. (has done for me in the past).


#9

hav always had skin zoom set to -4 or -5 to fit our TV screen as the default setting is too large to fit. But I will certainly try your suggestion and report back. Thank you for taking the time (along with Sam) to offer help.

Wendy


#10

Many thanks for the above help.

After trying to follow the previous advice(s) I ended up doing another clean install, this time retaining the default classic skin rather than changing to Confluence as in my previous attempts. I then adjusted my settings, piece by piece, rebooting in between to make sure all was well before making each following change/addition, thus trying to eliminate the culprit causing the sad face loop. I’m pleased to say that so far I have a good working system, almost as I want it apart from not introducing the Confluence skin as everything else appears stable and I am loathe to upset it. Does anyone know if Confluence has known problems?


#11

I don’t believe it does have any issues and it should be compatible but there should be a section for this skin on the Kodi forums where you may be able to get better support than we can provide.

Sam


#12

I will ask on the Kodi forum as suggested. Once again, thank you.


#13

Since you have learned some command line, you could save your current setting:

sudo systemctl stop mediacenter
cp .kodi .kodi.save
sudo systemctl start mediacenter

will make a copy of your current settings. You can then install Confluence and see what happens. If it fails, or you later try something and get sad face, just restore the know good settings:

sudo systemctl stop mediacenter
rm -rf .kodi
cp .kodi.save .kodi
sudo systemctl start mediacenter

This will restore to the last know good, and keep that as a restore point so you can experiment.


#16

@bmillham Thank you … a brilliant suggestion which I tried just now - copying the 3 command lines exactly to save the settings but unfortunately there was an error in the ‘save’ process as no .kodi file was found. After entering the ‘start’ command I ended up with a revert to OSMC skin with all of my settings wiped out. Happily I had done a backup prior to this and was able to restore from that. Did I do something wrong? I checked and double checked my entries to ensure I was typing correctly.


#19

Try cp -a .kodi .kodi.save


#20

Thanks. Instead of “cp .kodi .kodi.save” I presume? Will give it a try tomorrow. Appreciate the help.


#21

correct


#22

I was having a very similar issue this week on a 3b+ but mine was also corrupting the SD card after a number of reboots. Swapping the SD card and power supplies made no difference. I then suspected I might have a defective SD card slot so I made a LibreELEC thumb drive to run the system with no SD card at all but that too went into a reboot loop after restoring my profile. I then underclocked my CPU from the stock 1.4ghz down to 1ghz and everything is stable again (I left all other timings at stock). I don’t know why this is and it does not appear to be a thermal issue as stock speed was only running 105F.


#23

Always back off from an overclock first.

3B+ is 1.4Ghz however; so if reducing clock speed works it sounds like your PSU is the issue.


#24

I completely agree on both accounts, but since I started with a system and power supply that had been completely issue free for months, and then tried another known working PSU to no avail, i’m currently at the belief that my particular system has somehow degraded to where it no longer wants to run at full speed. As the issue with this OP sounded very similar to what I was seeing (other than a different model pi) I figured I would throw this out there as something to try. OSMC makes lowering your clock rather quick and easy after all :grin: