Sad face looping during boot

In the last two days I’ve been facing a problem that is still unresolved, so I ask you for a help.

Mediacenter doesn’t work anymore, I think after a dist-upgrade operation over SSH. It seems all went fine, so I closed my shell. The day after, when I switched on my TV I saw the “sad face looping issue”.

I tried to do a new update & dist-upgrade operation but issue still remain.

My system is a Raspberry 2 updated to the very last OSMC version, my full logs are here:

Thank you in advance for your attention.

Your log shows a lot of upgrade instead of dist-upgrade operations.
You might have run into a problem here that needs reinstalling osmc.

The error indicates a segfault. Could also be out of space or filesystem corruption.

Thank you @mcobit, you are right: in the past sometimes I executed upgrade instead of dist-upgrade, but the last time in which this happened was on 2016-04-16 and OSMC went fine until 3 days ago.
I think problem could be generated by filesystem corruption, in that case is there any solution that avoids reinstalling the entire OSMC?
Problem is on mediacenter, is it possible to force reinstallation of it?
Thank you again,

Have a look at the link below for some things you can try.
I’d strongly suggest checking the sdcard and powersupply though as this is the most likely cause of corruption.

You might as well want to backup your .kodi folder or use the backupfunction of myosmc and reinstall osmc on a new card.

Edit: for reinstalling the mediacenter package:

sudo apt-get install rbp2-mediacenter-osmc --reinstall

1 Like

Issue resolved:
This morning I had some time and I tried to revert modifications made by the last dist-upgrade operation. In particular I tried to force the downgrade of samba packets with this command
sudo apt-get install samba-libs:armhf=2:4.2.10+dfsg-0+deb8u3 libsmbclient:armhf=2:4.2.10+dfsg-0+deb8u3 samba-common:all=2:4.2.10+dfsg-0+deb8u3

Then I rebooted the system and OSMC started fine.
Is there maybe some incompatibility with last samba packages?

Probably something went wrong during the upgrade process.

You should definately try a dist-upgrade again. If the error is reproduceable, @sam_nazarko might want to have a look at it.
Might be related to

I can’t reproduce it here.

I suspect either a short lived packaging bug upstream or a Debian mirror with partially corrupt archives.

Thanks @mcobit and @sam_nazarko for supporting me.
I just tried dist-upgrade again and samba packages were updated. Now OSMC is running fine.

Yes – suspect it was a bad upload or problematic mirror; mainly the latter as it only affected some of our users.