Samba is not working


Since the update, I can’t connect from my home network to OSMC to the hard disks, can anyone else be able to help me? Greetings


EDIT: i use raspberry pi 2

Same issue here: after the latest update, Samba is not working.

sudo service samba status says:

● samba.service - Samba Server
   Loaded: loaded (/lib/systemd/system/samba.service; enabled)
   Active: active (exited) since sab 2016-12-24 14:20:52 CET; 2 days ago
  Process: 14167 ExecStop=/etc/init.d/samba.distributed stop (code=exited, status=0/SUCCESS)
  Process: 14190 ExecStart=/etc/init.d/samba.distributed start (code=exited, status=0/SUCCESS)
 Main PID: 14190 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/samba.service

In the /var/log/samba/log.smbd logfile, there are lots and lots of errors like this:

[2016/12/26 21:34:20.541658,  0] ../source3/lib/util.c:788(smb_panic_s3)
  PANIC (pid 32166): internal error
[2016/12/26 21:34:20.542151,  0] ../source3/lib/util.c:899(log_stack_trace)
  BACKTRACE: 0 stack frames:
[2016/12/26 21:34:20.542254,  0] ../source3/lib/dumpcore.c:318(dump_core)
  dumping core in /var/log/samba/cores/smbd
[2016/12/26 21:34:21.611182,  0] ../lib/util/fault.c:78(fault_report)
[2016/12/26 21:34:21.611353,  0] ../lib/util/fault.c:79(fault_report)
  INTERNAL ERROR: Signal 11 in pid 32167 (4.2.14-Debian)
  Please read the Trouble-Shooting section of the Samba HOWTO
[2016/12/26 21:34:21.611446,  0] ../lib/util/fault.c:81(fault_report)
[2016/12/26 21:34:21.611507,  0] ../source3/lib/util.c:788(smb_panic_s3)
  PANIC (pid 32167): internal error
[2016/12/26 21:34:21.612017,  0] ../source3/lib/util.c:899(log_stack_trace)
  BACKTRACE: 0 stack frames:
[2016/12/26 21:34:21.612131,  0] ../source3/lib/dumpcore.c:318(dump_core)
  dumping core in /var/log/samba/cores/smbd

This is the output of grab-logs -a

Was the samba package updates in the last update?

1 Like

We didn’t update Samba in the last update, but we don’t package it either. It’s done upstream

I tried with an update today and it went through fine. But I noticed one user had some dependency issues when updating. I suspect a Debian mirror may have hosted a bad version of Samba recently.

Running sudo apt-get update && sudo apt-get dist-upgrade should resolve this issue. If it doesn’t, post output, and try clean your local archives and update again before reporting back.

I’m keeping an eye on this issue. Thanks for your reports (@ildave, thank you for the verbosity).

1 Like

I’m having the same issue. Only happening on KODI on another device. I can see the samba share and connect but get error Broken Pipe when I try to open USB-HDD “folder”. I can access all folders on the sd card though so it’s just the external drive.

It worked fine before the upgrade and still works via a tablet using es file explorer smb share.

I tried those sudu commands and it didn’t fix the issue. I’m just using upnp as a workaround for now.

Yup same issues. Affecting my pi2 and pi3. Can’t connect to smb shares. Can’t recreate them either. Get error “software caused connection abort” worked literally minutes before the December update was applied.

Try a manual update via the command line again. One user reported this to work for them. It was likely a (temporary) upstream issue.

Nah…applied all the apt-get… mentioned. Didn’t help. The path is visible when creating a new share but as soon as you apply it fails. As if something has changed in security somewhere.

If you updated from a very old version of OSMC (April), then this is expected and answered in the forum.

Updated from November release to December release.

Not aware of any changes that would cause this. But can’t speculate without logs.

Just to clarify. The smb share is hosted on pi2 running latest release (December). Pi3 connecting to smb share using latest release fails. Before upgrading both (ie running November release on both) the smb share worked seamlessly.
At this stage it pretty much means rollback to November release

Will get logs

You will need to do that for now. I can’t fix or investigate anything without logs. Sorry.

I’m hardly a guru but I have uploaded all configuration logs to HTTP:// this is the smb host logs. There are loads of errors under the samba logs now.

Client logs have also been uploaded to HTTP://


You have DNS problems, possibly due to a misconfigured VPN, i.e.:

Failed: Couldn’t resolve host name(6)

So if you are adding your Samba shares via hostname, instead of IP (not recommended), you are going to have problems.

Your DNS errors will also prevent you from updating to a potentially fixed version of Samba (if the upstream repository had a bad version). So fix DNS first.

Thanks will check. Odd suddenly though and dns isn’t used internally but rather reserved IPs. Will resolve none the less and check.

Thanks again

I think you may be confusing DNS and DHCP.

Internally I use reserved IP for each osmc unit. They connect to each other via LAN. Each also has a wireless internet connection and can connect out. I have disabled wireless on all now and tried to create the smb share that used to work. I can browse the source - I.e I can successfully connect and navigate the connected drive on the smb server. However once in and attempting to select a folder it fails. I will flush etc and see if it’s a cache problem

I’m talking about DNS, not DHCP, so ‘reserved IP’ has nothing to do with this.

Your logs show that you have problems resolving hostnames. This will give you a lot of problems with updates, downloading add-ons, etc. You should resolve this first and attempt to update again via the command line, and you should ensure you use an IP address, rather than a hostname to connect to your Samba shares.

You can temporarily mount you Samba shares via /etc/fstab if necessary.

We missing each other. Let’s leave the dns etc for now. I can ping the server and then try and create a share using the same IP in the smb:// share. I connect to it successfully however trying to access the mounted USB drive fails. I can also navigate the root directory of the destination. However nothing can be saved as a smb path on the client. Samba is broken.