Sad face on ATV, logs attached


Trying out OSMC for the first time on my old first gen Apple TV. Install to HDD but the ATV boots up to a sad face. I ssh’d into the ATV and entered the commands from the sticky post (Problems when updating your ATV1 ? - READ HERE BEFORE POSTING!). After reboot I still get the sad face, so I’m not sure where to go from here.


Any help would be greatly appreciated!


Which version did you use?
Can you try a USB version first and see if that works as expected?

Avoid updates for now – as they are causing problems at the moment on AppleTV.


Hi Sam, wow quick reply!

I used 2017.03-1-HDD. That is the only one I have tried, I will try USB now…

There is a very rare, but (can happen) race condition.
Suspect it won’t be the issue, but try

sudo -s
systemctl stop mediacenter
rm -rf /home/osmc/.kodi
sed -e "s/console/anybody/" -i /etc/X11/Xwrapper.config
systemctl start mediacenter

Sam, I tried the commands you suggested but that did not resolve the issue.

I recreated the USB stick using the “USB”, and that one does boot successfully into Kodi. Should I try the HDD one again or just stick with the USB version?

I have just tried to reinstall from scratch the HDD version of OSMC, and now it is working! Not sure what was different but everything seems good now :slight_smile:

Still problems with updates for the atv? Just did a clean install to hdd from lastest image available, and an update from myosmc after. Update wanted to restart to complete, and that just went to black. Sad face after.


Good day everyone, dear Mr Sam, i have read lots of comments and posts but unfortunately i have not the skills than other guys in here, first of all thanks a lot for this amazing project, i do install the OSMC in my ATV using the Usb install, its just run perfect but today there was an update in progress which corrupts the program so once re start only a sad face comes up, thank God i make a backup image of my stick with all settings and adds on and i just make a re install of that and works fine again. These “updates” are important now? Can i just skip it and continue with the version already installed? My ATV has no CrystalHD installed, just a dongle for wifi and a stcik with the OSMC program. My warmest regards from Venezuela

Leave updates for now – they are unforunately broken for AppleTV.

I am working on this.


Well noted, thanks for your reply
This Vero box, could be available in my area? I mean, there’s only available to purchase in an especific currency which is not in use in my Country. Thanks for your time @sam_nazarko

We don’t have any resellers in South America at this time.

If you pay using PayPal you can use the currency of your choice. The delivery is quite prompt: 3-5 days.

Many thanks for your prompt response, all well noted and understood. I’ll try to do it from PayPal

Looks very interesting device.

Best regards