Sad face on music scan to library

Searched the forums and found: Sad face loop after update which was close to my issue, followed the reinstall steps and no change. I also think the issue is related to a .flac file. Noob, so I am not all that great at reading log files. Had months of success with current setup till today.

RP2 - NOOBS setup
NFS file share with Jessie
Wired connection

http://paste.osmc.io/ajipareran

You have not enabled debug before creating the issue in these logs.

sorry about that:

http://paste.osmc.io/cabavasago

13:20:46 1094.833252 T:1731507232   DEBUG: CNFSFile::Open - opened media/bret/61c59c71-6b11-46e3-90e3-47a732064d97/TheBeagleMedia/Music/Beck/(2005) Guero [EAC FLAC]/01 E-Pro.flac

Remove that file and see if it progresses further. Or provide new log again on failure.

Thank you.

TIL turn on debug before looking at logs and look at the end of the kodi log.

1 Like

It may be the file tagging that is hanging it up in the scan. You may be able to clear it out and re-write the tags to make it work.

I tried that, I rewrote it with Musicbrainz with no luck. I am going to investivate further but this solved the original issue. I will post any further findings. I plan to manually rewrite tag, re encode and tag again if that doesn’t work.

Give MP3tag a bash.

http://www.mp3tag.de/en/

On a side note, tidy up your folder names.
[eac flac] just makes stuff look untidy.

They were named using Picard (musicbrainz). Should I have different file name settings?

May be remove the file type between quote ?

Here is my naming script :

$noop(Various Artist Albums)
$if($eq(%compilation%,1),
%album% \($left($if2(%originaldate%,%date%),4)\)/
$if($gt(%totaldiscs%,1),$if(%discsubtitle%,CD %discnumber%: %discsubtitle%/, CD %discnumber%/),)
$num(%tracknumber%,2). %artist% - %title%,

$noop(Artist)
$if2(%albumartist%,%artist%)/

$if(%album%,
$noop(Album Tracks)
$if($eq($or(%originaldate%,%date%),1),
%albumartist% - %album% \($left($if2(%originaldate%,%date%),4)\)/,
%albumartist% - %album%)/
$if($gt(%totaldiscs%,1),$if(%discsubtitle%,CD %discnumber%: %discsubtitle%/, CD %discnumber%/),)
$num(%tracknumber%,2). %artist% - %title%,

$noop(Non-Album Tracks)
%title%
)

)