Sad Face Reboot Loop after IPTV addon


#1

Hi.
I’m stuck on a reboot loop after activate and configure IPTV add on.
I have trying rebooting and powering off and on. Menu loads and after 2 seconds it crash and then sad face.
How can I deactivate IPTV add on?

Thanks


#2

Do you know how to use SSH or WinSCP? You need to move a file called AddonsDb.

Alternatively you can reinstall OSMC if easier


#3

Hi Sam.
Yes I know how to access via Ssh.
After configuring the add on with the m3u url a message with Reboot is necessary appears and then the sad face.
It was the IPTV add on inside PVR add-ons section
Thanks.


#4

If you upload some logs via SSH it may help us see what’s going on


#5

Here you are Sam
https://paste.osmc.tv/yuculuzili
Thanks


#6

The add on was PVR IPTV Simple Client
In the 2 seconds that I see the main menu until it crash I can see a new PVR icon that wasn’t there before


#7

Hi.
Finally reinstalled osmc as I wasn’t able to solve the reset loop
Cheers


#9

Please post a log

Thanks

Sam


#10

@sam_nazarko This seems to be older bug with Simple IPTV addon (https://github.com/kodi-pvr/pvr.iptvsimple/issues/173) which causes buffer overflow while logging, there was workaround PR to fix it which was here: https://github.com/xbmc/xbmc/pull/13984

So it looks like a regression after October update, let me know if I can help in any way.


#11

Thanks for letting me know. I’ll check this out.


#12

Hello, I’ve been a Vero 4K user since October 17; first post on here.

My first experience of using OSMC and I love it. To date, I’ve had a couple of minor issues (blue light stopped working and occasional sad face watching a show, but really no biggies and overall very happy.)

Tonight though I experienced the issue mentioned here - a sad face boot loop following an OSMC and IPTV re-install.

Briefly, I reinstalled OSMC via USB (for first time), process was flawless.

Re-installed my IPTV client (it was previously working perfectly) but it had recently stopped working as their new installation procedure now requires activation of Simple PVR client.

So I re-installed OSMC; activated Simple PVR client and re-installed IPTV add-on, so far so good.

However when I tried to run the IPTV client the Vero went nuts! Kodi would start up, it would run for a few seconds then crash, unhappy face; then process would start again and loop.

Some lines of code would appear at the top as Kodi started.

The only way I could break the loop was to pull out internet lan cable just after Kodi started up. Then I de-activated simple PVR and the loop was broken.

I tried to reinstall OSMC again but can’t, it just loads up Kodi again, with IPTV add-on still there.

To be honest, I predominantly use my Vero to watch media from a hard drive so it’s far from a disaster as this works fine. It was just nice having the IPTV as a backup to watch the odd show.

Did a forum search and found this topic on here. Definately sounds like the same issue.

Finding a workaround is far beyond my technical abilities so was wondering if there’s any possibility of a fix? The IPTV add-on works fine on my old Android boxes but would just rather use my Vero!


#13

It will be fixed in the next update which will be ready in a few days. Keep an eye out for the blog.

Cheers

Sam


#14

Brilliant Sam, thanks for that and for the fast reply, much appreciated.