Sad face reboot & SSH not working

Last night my Vero 4k+ decided to give a smiley face and reboot. Just finished watching a show and it was on the tvshow list screen when it crashed. Once kodi pulls back up I have about 5 seconds before it reboots again. I have tried to exit Kodi and go to the OSMC prompt, but it just crashes.
I have tried to access via SSH, but it keeps telling me the username/password is invalid.
(SSH worked last week with no issues, so I know the password)
I have left the default, as this is internal only, and there are no ports forwarded to this.
The last OSMC update was (I think) about a month ago.

I did install VNC last week, so I can work on updating shows without being on the TV.
This still works, but again it crashes after about 5 seconds.
Recently did some directory changes and blocked scanning certain sub folders.
No changes have been made for about 32 hours prior to it crashing last night.
Had watched TV Shows the same day as the last changes, and the following night watched 1 show before it crashed. (sorry if I am repeating myself)
Not sure how I can do any troubleshooting using SSH if it will not stay running.
As an FYI: I did also open a support ticket from my OSMC account.

Any input or suggestions would be appreciated.


Some logs should show us what’s going on, but if you can’t login via SSH that’s not going to work. Was the device possibly exposed to the internet / port forwarded?


You could try to connect USB keyboard and try pressing ESC after the smiley

Hi Sam, No port forwarding is setup. I run my own router and keep everything pretty tight.

Thanks for the idea Fzinken, I tried that and it prompted me for the device login. When I input the user name sometimes it will ask for the password, other times it will just boot into Kodi and then reboots again.
on another subject how can I change the (my) name that shows up?


As another piece of info, When I run a constant ping to the unit, I do not see a complete drop when it reboots, but I am seeing the time jump from 1ms to 5ms for a 1-2 pings. So not sure if it is doing a full OSMC reboot or not, but it appears to be.

Which name. There is three; one for the profile name (settings>profiles), one for Kodi/UPnP (settings>services), and then there is the hostname which is part of the OS and you change it whatever the normal way is for Debian Linux, although I think there might be something that tries to sync it with a change in settings>services if you do it through the UI.

Obviously it is a bit tough guessing largely blind, and a bit tough not being blind if you lack the abilty to access the system using any normal method. I’d take a stab in the dark and try a different power supply. If it was only Kodi crashing it should (that was a stupid typo to make) shouldn’t affect ssh access at all so this “feels” like something other than Kodi to me.

user name? I thought it only asked for a password. The timer is pretty short from what I remember when I was there last.

No, the sad face just indicate a that Kodi fails and restart. The OS is not impacted by that. Therefore also things like SSH should not be impacted by the sad face as they continue to work.

If you write about a ‘reboot’ loop, you see again and again the red LED of the Vero 4k+?

Rainer, do you perhaps have a USB cable with the USB-A port on both sides? Or a USB extension and a USB-A to USB-A adapter?
In this case, you can try to power the Vero (just for testing!!!) without the power supply but via a USB port from the PC or charger with a USB port.
If you have a suitable power supply in your household, you must DEFINITELY make sure that it has 5V but no higher voltage!!!
In case it boots then successfully, we know it’s the PSU which is at the end of its life cycle.

Name Change, sorry I completely botched that question. I was actually referring to the name that shows up in these posts. Mine shows my username: flaB8xMUcV, I wanted to make it more friendly, but do not see a way to do that.

I will look for a power supply, as I have a box full of them, and may have a couple adjustable units.

When hitting the ESC key on reboot, it asks for a username and password. My only point here is (what you just pointed out) that it does not allow much time before trying to boot back into Kodi

Just not sure why it is not liking my password on the SSH.
Starting to worry now about a possible hack, but just do not see how that is possible with no port forwarding to the unit (or any device). From my understanding the Linux/Pi version of VNC does not have that wide open “direct from web” type of access, like the windows version has. Am I wrong on this?

I had not noticed the light situation. The light comes on when I plug it in, but does not come on again during the recycle events. So that seems to prove that it is just Kodi that is crashing.
My power supply has a round plug. Will see if I have another 5V unit to test with. But are you saying that I can run this just by plugging in a power supply (5V only) into any of the USB ports?

I will get back shortly with the power supply results.

With all of that, then I guess the question is: if the SSH password is not working, is my only option to push out a new image to the unit?

I do appreciate all the help you all are giving.

Okay, found another 5V PS from an android box and tested with that. Same reset happening, so not a power supply issue.

Another bit of information: When inside of Kodi and I try to go to System, and the My OSMC, most of the time it just restarts kodi, but this morning I got this message: My OSMC service is unavailable Please wait a few seconds and try again. I have to be very quick to click on My OSMC to get this message otherwise it just reboots (resets kodi).

At the top right of this site there is a hamburger menu with an option to show “My Posts” which will take you to your profile page which contains a “preferences” link.

That is expected behavior on all systems.

You did make a backup previous to this didn’t you? :grin:

If you are able to be in Kodi for a few seconds I recommend to go to power - exit and press ESC. That should give you enough time to see the console and login.

That did the same thing as going to System My OSMC, but worth a try.

I had found that and there is a name in the “NAME” box, but still shows the username. Not a big deal.

No, I do not have a recent backup. It will be a headache and time consuming but it is raining today, so not doing anything else. :grinning:

I am still concerned about why this happened, could the internal drive be going bad?
The fact that the password is not working really bothers me, as I used it to install VNC last week.
VNC is internal only, not port forwarding, but think I need change the password when I install it next time. It is just so much easier to do setup on my computer instead of on the TV.

I’ve no clue on the password but Kodi crashing sans a user manually making changes could happen due to a add-on that got updated and something went wrong there as they update daily and silently.

Well, I am in the process of reloading, hopefully it will go smooth.
I will update again once it is working.

Thanks to everyone for the help and advice.
I have it reloaded, and hope it does not lock up again.
I have already scheduled the auto backup of Kodi (was doing it manually before).
And once it gets done importing all of my shows again, I plan to do the export backup again.
That is something else I have not ran in a while.