Sad Face when casting from NAS or Playing via Emby

My current set us is that my TV shows are on my NAS which has the Emby app installed, I have also installed the Emby App which links it together.

I can play Videos 2 ways:
Cast it direct from the NAS direct to the V4K
Or Play via the Emby App on the V4K

However whenever I do either of these I usually get teh Sad face after a minute or 2 of playing, and Im stuck as to what is causing it.

I dont think its the videos themselves doing it as sometimes it will crash when im just using V4k normally.


Any help is greatly appreciated.


What’s the NAS and has it ever worked?

I run Emby Server on a Debian box and use the Emby add-on on a Vero 4K and it works without issue, even with all the media files on a third machine.

Unfortunately, this might be an Emby issue, in which case you might have a better chance on the Emby forum.

NAS is a QNAP TS-251+, Its never worked on the V4K but its works streaming to other devices fine which is why I think its V4K.

Also like I said It will sometimes just crash without playback usually when its updating the media library.

Other devices running Kodi?

Needs to be a Kodi debug log to see the possible issue.

Funny enough, had an email from a Pi user using Emby today reporting an (apparently known) problem with the Emby’s Library Sync add-on.

Worth disabling this add-on if you have it to check if that’s breaking things


Thanks I will action both of these tomorrow.

Hi Here is the Kodi log

When you posted this log, had you experienced a crash?
Have you tried disabling the add-on?

A full set of logs if/when it happens next will help


I disabled the emby plugin but it still crashed not long after.

Your system appears to be configured to obtain its media via the Emby add-on:

19:42:30.480 T:4108369920   ERROR: Unable to find plugin
19:42:30.480 T:4108369920   ERROR: PlayMedia could not play media: plugin://

So it looks like disabling the Emby add-on is removing its data source.

Yeah thats why I disabled, im going to uninstall it see if that helps.

New log updated now no mention of emby plugin.

You’ve provided a log but not told us what error you had.

But looking at the log, I can see no mention of any media being played. Might this be because, having removed your media source (the Emby add-on), you have not defined a new source to replace it?

No media was being played this time when it crashed.

I can see nothing obvious in the log. It might be that a reinstall is necessary but for now try this:

sudo systemctl stop mediacenter
mv .kodi kodi.bak
sudo systemctl start mediacenter

this should re-create the .kodi directory. You’ll need to reconfigure your data source again but it will effectively be a fresh Kodi configuration. (You still have kodi.bak, so nothing has been lost.) See if this makes a difference to its stability.

I did what you said and ive currently got nothing else added on. Ive been casting over teh network to the Vero4k. It had been working fine for a few TV episodes but it crashed again.

Here is the log

Files I cast are usually 1080p MKV files.

Please don’t supply cut-down logs. Use grab-logs -A or we won’t have a clear picture of what’s on our machine.

Does it work playing files “normally”, ie not casting?

Two points from the beginning of this thread:

  1. You metion “it works streaming to other devices” but you never answered if the other devices were running Kodi.

  2. Have you raised the matter on the Emby forum? They know their product and are usually very helpful.

Sorry I should clarify a couple of points.

When im “casting” its from windows ie right lick and select cast to device and chose OSMC. I haven’t tried playing files locally yet I can try this next.

I dont see why going to Emby forums will help because I have ruled that out being the issue as far as im concerned since its not installed on the Vero4k anymore and im not casting it from the Emby server. Its being “casted” from drive using SMB.

Thanks for the clarification. I don’t use Windows, so can’t even try to reproduce the issue. Perhaps someone else can help.

Just to clarify, which version of Windows are you using?

Windows 10.