Sad Smiley Face ATV1 after manual USB update (Sept2016 OSMC working)

Hi,
I’m ATV1 (crystalHD) into a CRT TV.
Updating because old install went weird.

Internally updating OSMC ended up with “Sad Smiley Face”.
Then tried manual install. Got :frowning: and “HD Question Mark” on various versions of OSMC.
Finally an ATV1 Factory Restore got me out of trouble and back to square 1 :slight_smile:

Tried September 2016 OSMC. “Successful Install”. OSMC Logo. Then Black screen.
This happens with my CRT TV attached via Component to RGB SCART converter.
The xorg.conf file needs to be edited for the correct refresh rate.

Using Terminal: ssh osmc@192.168.0.15 (pwd osmc) I got in.
Used Chewitt’s method to place his edited xorg.conf file back into OSMC:
sudo wget http://sprunge.us/gNEJ -O /etc/X11/xorg.conf

Finally it worked. OSMC running on CRT TV :slight_smile:

Then sadly I updated within OSMC and got back to the Sad Smiley Face again :frowning:

Tried to reinstall OSMC (September16) but it didn’t work.
Tried ATV Factory Restore (factoryrestore3.img.zip) no luck. Stuck on the Loading Page as before.
Tried Fac Restore with factoryrestore2.img.zip and it worked :slight_smile:
Weird logic.

Reinstalled OSMC Sept2016 and it worked.
Put in edited xorg.conf and it is working again!!! :slight_smile:

The volume was very low so had to do this line in Terminal:
amixer set Master 150% unmute > /dev/null 2>&1

I don’t think 100% volume equates to 0dB. Adopted the Spinal Tap method.

All working.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Please provide debug enabled logs so we can try to diagnose the problem.

1 Like

Not sure if the log files will help because I have done multiple installs of OSMC and ATV Recovery.
Surely the logs will only be for the working OSMC (Sept2016img) install and not the latest which didn’t work.
I apologise for not grabbing them. I hope this still helps as a pointer list for people with the same setup.