Sad Smiley Face since some days

Using OSMC (17.8-084) on a Raspberry Pi 3.
So since some days i get the sad smiley face after every “reboot” command trough SSH or if I use the Restart Button in the GUI.

Only if i type shutdown -r now it works again, sometimes even that doesnt work and I need to retype shutdown -r now.

Dont rly now why - also tried to rename the .kodi folder to .kodibackup but didnt helped.

here are some logs:

But they look pretty same.

If the Log Files are wrong, let me know.

Suggest to enable debugging (see How to submit a useful support request - General - OSMC) to help finding the culprit and also provide full logs (easiest with grab-logs -A)

I’m curious why you reboot so often? I only reboot mine when needed because of an update, or power outage. 30 days or more is normal for me.

If you are rebooting because of random problems, then I’d suspect your power supply.

Just wanted to point out that the problem occurs everytime if i type “reboot” but not shutdown -r now.
Since yesterday even shutdown -r now doesnt work @bmillham

Iam pretty sure that i enabled the debugging. BEFORE i couldnt even get the gui working with shutdown -r now
Here is one more log:
If that is also not right, then i cant help you because i cant get in the GUI to enable the setting.(Sad smiley)

I have also a problem with: grab-logs -A
This error comes:

#Edit: grab-logs -A works now, after the reinstall of libpython2.7-minimal and libpython2.7-stdlib

SD card is corrupted

What makes you think that? @sam_nazarko

That very much points to a broken SD card as @sam_nazarko indicated.
If you want to check it write some files to it power down than start and check if the files are still there

Your screenshot with python error.

Complete Shutdown and then replug the power supply? Or just a simple reboot or shutdown -r now?
Because the new file that i created under /home/osmc/Test/ is still there after a reboot.

Well would do a full power off to verify. Also write a bigger file.

Alright, will do it after the libary scann is completed (Sad Face disappeared after i changed 2 times the kodi folder and had it off for some hours).

I had also the x11 Launcher installed before i renamed the kodi folder:

Could that be also a problem? Because right now i didnt installed the launcher/addon (dont know how to name it correctly) and had 2 successful reboots.

Uploaded a 100MB File to /home/osmc/Test

Typed shutdown
Waited 5 minutes
Replugged the Power Supply from the Raspberry

Checked the File - still there (No Sad smiley)

Well that seems to be fine. Till strange why you had all that strange issues before.

So now everything is working even when using reboot?

Yes - lets see what happens next.
Thanks for your time and of course to the others who replied.