Sad smiley on boot

Hi ! (sorry for my english, i’m french)

Since some time, when I launch my raspberry PI 3, OSMC don’t boot and display me a sad smiley in a loop. I tried to resolve the problem with command line (in SSH) : sudo apt-get update and sudo apt-get dist-upgrade but the sad smiley is still there.

I’m just beginner, I need explanations to repare it.

  1. What do you define as “some time”? A few days or weeks?
  2. Assuming that you did the reason upgrade read the Krypton FAQ (should be pinned on top) for possible solutions
  3. If not solved afterwards provide debug logs

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thank you for your quick answer.

I don’t use OSMC regularly so it’s difficult to say when the problem happend but I saw the problem about 5 days ago.

I have already read some post on the same problem but it seems that the “sad face” is shared with many problems.

Sorry for my ignorance, how can I provide you the debug logs ?

Thanks in advance

Check the link I shared.

But before I really recommend you try moving the .kodi folder as explained in the Krypton FAQ

I had already try to move the .kodi folder, I just retry now and it don’t works.

Here I provide you my debug logs : http://paste.osmc.io/gehukaxoto

You haven’t mentioned you have already tried to move the folder, the command you listed above is not what we are talking about.

As per the FAQ:
Q: I’ve installed the update and now I only have a black screen or a sad face loop, how do I fix this?
A: It’s possible that your Kodi userdata is causing an issue with the new version. The first recommendation would be to move it away and allow Kodi to generate a new userdata directory. This can be done by executing the following commands after accessing the command line58:

sudo systemctl stop mediacenter
mv ~/.kodi ~/.kodi-backup
sudo systemctl start mediacenter

This fixed it for me however you will have a blank slate.

Doesn’t look good, kodi crashes very early. Suggest to make a backup and reinstall clean

OK, have you a link with a description step by step to do a back up and reinstall clean ?

And thank you, I was afraid that I must reinstall… If i do that, all the configurations I’ve done will be erase (I had install Samba, transmission, FTP server, etc :confused: ) ?

Sorry no step by step description.
You will have to backup at least the directories /etc/ and /home/osmc/
You could either do that via winscp or on OSMC via a NAS

Here is a cheatsheet for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

Thank you, I just need to copy the /etc/ and the /home/osmc/ directories for the backup ? I have a SD card reader on my laptop, will it works ?

Which OS?

That are the important directories with configuration files. You would need to reinstall all addons and programs.

Windows 7

No Windows can not read the OSMC partition.
Either you have to use winscp to copy the files via network or use a live usb Linux

with this software you can read linux partitions with windows:
Freeware Linux Reader for Windows

I had a similar problem after installing the initial Krypton update.
In my case it seemed to be resolved by unplugging the USB cable which was connecting a Dualshock 3 controller to the Pi3.
Once removed the Pi3 booted normally.

I had only 2 external usb HDD. I had unplug and unmount them and nothing change. I have a screen conect with HDMI and a microUSB power supply too. Linux is still running beacause my murmur server (VOIP) and the FTP server works. I think I will reinstall OSMC.