Sadface bootloop on Vero 2 after last update

Here are my logs: https://paste.osmc.tv/hobaxemaza

maybe relevant or not, i am using the following services next to kodi on my vero 2:

  • matrix-synapse
  • pi-hole
  • forked-daapd
  • open-vpn (bridged)
  • tranmission

everything works fine but kodi itself.

Have you tried with a clean kodi configuration just to exclude that as a problem source?

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

sudo systemctl stop mediacenter 
mv /home/osmc/.kodi /home/osmc/kodi.bak
sudo systemctl start mediacenter

If need you can restore:

sudo systemctl stop mediacenter
mv /home/osmc/kodi.bak /home/osmc/.kodi
sudo systemctl start mediacenter

same problem with default configuration: https://paste.osmc.tv/eyinadunix

i temporarily disabled the openvpn-bridge just to make sure it has nothing to do with that and it gave me the same result.

Thats only the apt log (you used -a instead of -A)

et voila: https://paste.osmc.tv/odimodexan

Well at least it get’s much further then before, unfortunately not sure what is going wrong

2019-11-20 11:07:08.474 T:2796528352  NOTICE: Register - new cec device registered on cec->Amlogic: CEC Adapter (0000:0000)
2019-11-20 11:08:52.569 T:2951282688  NOTICE: Quitting due to POSIX signal
2019-11-20 11:08:52.616 T:2951282688  NOTICE: Stopping player
2019-11-20 11:08:52.616 T:2951282688  NOTICE: Stopping all
2019-11-20 11:08:52.616 T:2951282688  NOTICE: ES: Stopping event server
2019-11-20 11:08:53.223 T:2729386720  NOTICE: ES: UDP Event server stopped
2019-11-20 11:08:53.610 T:2951282688  NOTICE: stopping zeroconf publishing
2019-11-20 11:08:53.616 T:2951282688  NOTICE: CWebServer[80]: Stopped
2019-11-20 11:08:53.616 T:2951282688  NOTICE: stop dvd detect media
2019-11-20 11:08:54.039 T:2771350240 WARNING: CPythonInvoker(0, /usr/share/kodi/addons/script.module.osmcsetting.updates/service.py): the python script "/usr/share/kodi/addons/script.module.osmcsetting.updates/service.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon7xbmcgui12ControlImageE,N14PythonBindings31XBMCAddon_xbmc_Monitor_DirectorE,N9XBMCAddon7xbmcgui6WindowE
2019-11-20 11:08:54.163 T:2951282688  NOTICE: Application stopped
2019-11-20 11:08:54.363 T:2951282688  NOTICE: XBApplicationEx: destroying...
2019-11-20 11:08:56.067 T:2951282688  NOTICE: unload skin
2019-11-20 11:08:56.098 T:2951282688  NOTICE: unload sections
2019-11-20 11:08:57.894 T:2951282688  NOTICE: XBApplicationEx: application stopped!

true, i realized that as well. i even got connection to the chorus-webinterface for a very short time …

so … any other suggestions for a real troubleshoot? (resetting and starting from scratch can not always be the solution )

Re-install Kodi:

sudo apt-get install --reinstall vero2-mediacenter-osmc

Sam

already did (see previous thread: OSMC's October update is here with Kodi 18.4 - OSMC)

actually it seems to be working now, i figured it was not starting up correctly because the beamer attached was not on (probably needs it to determine a resolution at fresh start)

You can hardcode resolutions if necessary.

Sam

yes, thanks for mentioning (i did not restore my disp_cap after starting a fresh kodi).

is this is still the right way to do it?

: ~/.kodi $ cat disp_cap

720p
1080i
1080p
720p50hz*
1080i50hz
1080p50hz
1080p24hz

Btw. i figured that kodi was just failing because of little space left on the device. Is there a good way to clean the osmc-system or do you know of files/packages i safely can get rid of to free up some space?

cheers
bendsch

1 Like

Try:

sudo apt-get clean
sudo apt-get autoremove

Sam

yes i tried that … there was not much to clean out …

how much free space is recommended to run a stable kodi on osmc?

I would say it depends on your library. Did you removed the backup copy of your .kodi directory?

You also can install ncdu to check what is using the space

I would say it depends on your library. Did you removed the backup copy of your .kodi directory?

yes of course, i moved it to a remote drive. also i moved the “Thumbnails” Folder there via symlink (as suggested somewhere in kodi forum).

You also can install ncdu to check what is using the space

yes i’ve looked into it, thats why i was asking for specific packages, files you know of that are not absolutely necessary

~/.kodi/userdata/