Samba, NFS

Hey guys, is samba broken ?
I can’t acces my HDD drive on the PI from my Windows machine. Try to recreate the network link on windows but this doesn’t seems to work. I’ve read that NFS is hard to setup on windows somewhere, and i’m a bit lazy.
Can samba still work ? smb://192.168.1.x/name_of_the_drive just cannot connect (i can’t remember the correct syntaxe of these \ or / but i tried both )
my HDD is mounted in media ( i know but i’m insecure how to permanently mount it in /mnt without breaking shit up ) and i don’t know if you miss info, probably tho.
Thanks and have a nice day

Logs via grab-logs -A

Are you trying to access from Kodi on your windows machine or via file explorer?

here and thx :

i’m trying to setup a netword drive on my windows machine to access via file explorer the Hdrive connected to my kodi ?
I dunno if that’s clear.

Did you reboot after you installed the Samba server?
On the windows machine what happens if you run this in command line
net use \\\osmc /user:osmc
and then
net view \\

yes i did reboot.

I used the windows commands and got connected apparently. was it for testing only ?
Samba 4.5.16-Debian

Nom du partage Type Utilisé comme Commentaire

osmc Disque (UNC) OSMC Home Directory
La commande s’est terminée correctement.

I dunno much more

Yes for testing.
So if you now on the windows machine in the file explorer type \\\osmc does it show the folders of the osmc home directory?

It’s saying that the network name is incorrect when i’m trying it.

but i just re-tried \\media\PoupiStock and he says that the username and password are different from osmc

a bit lost now. Should i look into rights and propriataries of the folders ?

Not sure what you mean by that? Did the username/password dialog popped up and you entered the right credentials

i did (osmc:osmc aren’t they ? ) but then a dialog error poped out sayin that the netword folder specified is already mapped with a different name and a password. i should try to disconnect all existing mappage on this shared network.
SOmething like that, sorry i’m translating on the go

change to:

Yes, maybe you mapped it before when you had configured different username/password.
So check all credentials settings on the windows machine

Same problem with \\\PoupiStock

not sure how to check on windows these settings. i had libreelec before but i switch so you think these are still configured even it’s not the same IP ?

Not a windows expert, but google credential manager.
Anyhow if using a different IP I doubt that would be your problem.

Maybe try from commandline again.
net use \\\PoupiStock /user:osmc
and then
net view \\

tried this net use \\\PoupiStock /user:osmc and prompt said that multi connexion with more than one user aren’t allowed, i need to kill the first one.

I have absolutly no idea how and where :confused: thanks anyway, i’ll have a look into that

Use net use to figure out the current connections and then use e.g. net use /delete \\\osmc to delete it.

thanks, i just found it and did it, so now the commande net use \\\PoupiStock /user:osmc give me ‘can’t find network name’

Thats really odd. Suggest to go back to OSMC and then run
sudo apt-get install smbclient
smbclient -L localhost to figure out the shared drives.

OHMY ducking fog, i installed smg client via kodi, didn’t do it in the terminal.
smbclient -L localhost give me some things, not sure how to interpret that.
Sharename OSMC Disk OSMC Home Directory that should be why i can’t access media ?

EDIT: yes ! thanks a lot boys, in fact that was my fault all along, just sudo apt-get install smbclient and reboot, and i can create the network drive via smb…
my bad all along i thought that smbclient on kodi app was enough, should have look a bit. Have a nce day boyz,

No smbclient was surely not related to your problem. That was just to install the client to check.
My gut feel is the reboot solved your problem.