Samba Server requiring newer Authentication Method (Kodi Client)

I kow it’s an old thread but I encountered this exact error when upgrading my RPI to Debian 9. Not the one running OSMC but the one running my Samba.

To resolve the issue of “not connecting” I had to disable those 2 lines you added :

#       client use spnego = no
#       client ntlmv2 auth = no

in the .smb/smb.conf.

If I don’t do that, I can’t access my user/password protected share anymore

I have moved your post to a new thread as this is not related to an OSMC update (as the original thread was) but an update on the server site.

OSMC will move to Samba 4.5 (as server) soon also at that time also client settings most likely will be updated to enforce ntlmv2.
Also good to know this currently only impact access from Kodi, if you have fstab based mounts they should work fine also without this.

No problem. I only answered to the thread because it’s the first result on google.

And I confirm, using automount resolve all the issues.

Only when we move to Stretch
For now, we need to patch Kodi’s smb.conf.