Samba speed 25% slower after update

VeroV, Samba from PC via ethernet, speed to USB3 drive has dropped 25% but is faster VeroV to PC but not as fast as before update. I have been getting 95MB/sec consistently for a few months, now it is down to 60-70 MB/sec. I have also been having problems with the remote control response since the update.

Maybe something changed in the network, we suggest to check your network with iperf3. Please read this howto

You really need to get results from iperf3, because the slow down may just be an SMR HDD getting closer to max capacity.

All 3? 2TB space on TV Progs HDD🤣

I don’t know your setup.
You didn’t specify your hardware.
I just threw that out there as a potential reason why you may be seeing slow down in write performance.

I did say it started after the update and it has been really fast for a few months. If I serviced my car and it then started leaking oil I would suspect that I had caused it until I was proved wrong.

So what are your iperf3 test results?

As I said, iperf is hopeless to do on a PC, I tried sometime ago, so much to install to get it to work, unless you can guide me

Last time I used iperf3 was on the 4K+ so now with the V this was a great opportunity to do this from scratch.

In a nut shell, you need to install iperf3 on the Vero and on you PC, then tell the Vero to run the iperf3 server, then run a test from your PC as a client.

Installing iperf3 on the Vero:


sudo apt update


sudo apt install iperf3 -y

That takes care of installing it on the Vero.
Now to install it on your PC.

Download iperf3 from

Extract the two files into a directory of your choosing.
For simplicity you could just extract it to a folder called “iperf3” on your desktop.

Now SSH into your Vero and tell it to run the server:

iperf3 -s

Then open a command prompt in Windows at your iperf3 folder and run this command:

iperf3 -c <IP>

Where <IP> is the IP address of your Vero.

Here’s an example of a test I just ran:

1 Like

Thank you, I will try that

I can confirm too that Samba transfer speed decreased after the update.
I ran iperf3 and the results are what they supposed to be:

Wired 1000 Mbit (both sides): upto 940 Mbits/sec
almost the same as on @Kontrarian screenshot.

But Samba transfer speed is nonetheless down.

What were the previous speeds?
When did you last test and on which OSMC version? How did you test?

Nothing changed from an OSMC perspective re Samba in the last update.

Sam, I didn’t perform any formal tests before the update. I can only tell that most of the time when transferring files from windows system to HDDs connected to Vero, the speed was around 30 MB\s. Same as was for OSMC on RPi-4 on the same network. After the update, the same setup, the same networking, the speed is in 20-25 MB\s range. I’ll keep an eye on it.
USB3 HDDS are connected to Vero via USB hub.

Same as my experience, I got 90MB/s and now only 60 to 65MB/s

How is the drive formatted?

All ext3

I just tested sending a file to one of my NTFS drives and one of my ext4 drives.



My NTFS drive stayed between 20~25 MB/s and my ext4 drive was between 100~110 MB/s.

Worth noting, both drives are Seagate Barracuda 8TB SMR drives and my NTFS drive has 97.7 GB free and my ext4 has 2.65 TB.

I reformatted my 3 drives to ext4 a few months ago on Sams suggestion, I was getting 90 to 95MB/s until this latest update, now around 60MB/s

Can you post a log so I can see if any Samba related packages received an update?

Logs posted but not showing on here, at …/usufucilid