Samba with android on osmc

Hi. so i was using samba on my computer to transfer files to my pi 2 then i started thinking if i could get files from my pi to my phone so i went on the app store on my phone and got esfilemanager and used the lan option. i did that but i could not get into the osmc file this is the path.
but i’m stuck at osmc. i click on it but nothing happens.
Please help

tried with esfilemanager, and found it as annoymous but when i try to enter credentils i get server not found.

Tried with “Networkplaces” app, i find it and see the shares, but when entering credentials i get the same question for cerdentials over and over again.

gonna check logs for problems

Huh, I have used ES File Explorer (the classic non-bloated version that works perfectly and does not get updated automatically to the latest bloated version) for a long time now with OSMC and it always worked. Not sure why it doesn’t work for you. I will test again tonight.

The only issue I have and I hope OSMC devs will change it: after accessing OSMC via samba, I end up in the /home folder and it can be difficult to get to the /media folder containing my actual content (USB drive). OSMC should ‘know’ the content is on USB storage or network storage (/mnt?)…

Just tried with X-plore and no problem

using pro version of esfilemanger, just 6 months old so might be the “bloated” version

Have you installed Samba server from MyOSMC store?

yeah i have, works like a charm from the laptop, but i dont think the apps connect is propper.

STATUS=daemon ‘smbd’ finished starting up and ready to serve connectionscreate_connection_session_info failed: NT_STATUS_ACCESS_DENIED
in log.smbd

So it’s probebly the android app, since samba works good from laptop.

My bad, i had recently changed password on osmc account, when i used the old i got in to the shares with both android apps. The smbd deamon hasn’t updated the password, should have tried that from the beginning

The samba server password is independent of the ssh password. Use ‘smbpasswd’ to change it.


I have the same problem as descibed above. I can login via samba form my Laptop to my osmc media center and the connected NTFS hard disk (rasPi 3) but not from my Android phone / tablet.
I installed samba via the osmc app store. The only thing I changed is the default osmc samba password via “smbpasswd” which apparently worked as I can log in form my laptop.

On my phone I use the es file explorer from the google app store. Any ideas?


PS: I’m still quite a noob on Linux…

Just setup SFTP under FTP server with ip address and osmc:osmc as user:pass.

Hey thanks,

will try as soon as I’m home. I have changed the default password, so I use my new one.

Nope, did not work. After some time i get a message ‘server not found’. I did not change any other setting in the log in apart from my ip, username and password.