Samsung Remote Control not working with Raspberry


I have recently set up a RaspBerry Pi with osmc, i have connected with TV Samsung RU7475 but the remote control (BN59-01270A) is not working at all, and Anynet+ is enabled on samsung TV Settings.

I have also tried to configure it with the Samsung universal remote app, but i can’t find any product like Raspberry/Vero/Pi etc…

Please help, i am on this problem from a long time.

Thank you.

Try powering down at the mains for 10 minutes, this can fix CEC issues.

Thanks for your reply.

I have already tested this, and didn’t work, i have tested on 3 samsung TVs and didn’t work at all.
But i remember that last year i used it with an older tv and with standart samsung remote was working fine.
But now with new samsung 4K UHD TVs didn’t work.
I have already installed OpenElec to test if it will work, but not working.
Should i add somme configuration somewere or what ?

Please help, i am really stuck at this :frowning:

Try a different HDMI cable.


Thanks for you reply.

I have tested a new original Sony HDMI cable on an old samsung TV, with standrat remote control and it works !
But when i tried to test same cable with new samsung 2019 UHD TV not worked att all !
I think i must do something to enable the remote control, or on raspberry pi.
Also, the Anynet CEC option is enaled on settings on TV.
And when i try to enable with Universal samsung remote control app, i can’t find anything related with raspberry/vero/linux/etc…
Should i do something manually ?
Thanks for your help, really.

I am not familiar with how this TV works but I think your issue is that you are trying to configure a remote to control with IR commands for a Raspberry Pi that you don’t have an IR receiver connected to. It would seem you need to set your remote to use CEC for the Pi. If you read through the following I think you will find some insight into your issue…

I can also confirm this. My OSMC was working perfectly with my Samsung smart remote control. The update from october 18.4 totally broke this functionality!

I have tried to recreate the connection to the RPi3 running OSMC from my Samsung, I tried moving it to another HDMI port…nothing. This doesn’t work anymore.

I restarted the TV and OSMC. This didn’t fix the issue.

The Samsung remote control worked out of the box using the Anynet+ feature of my TV and I could control the OSMC using it.

Try powering down everything at the mains for 10 minutes.
We haven’t changed anything regarding CEC in this update.


I have a Samsung 4k tv also and very occasionally the smart remote doesn’t work through cec. It always comes back eventually though. Sometimes leaving the tv in standby for a while does it but ive never really tracked down the exact solution. I just keep the vero remote handy for the very few occasions i need it.

OTA updates, distributed regionally on these TVs make debugging CEC an uphill battle unfortunately.


surprise surprise today it’s working. I didn’t do anything. So like you said it must be some strange sleep mode they get into