Samsung TV series 7 remote using HDMI


I bought 55" Samsung UE55MU7072 and I can’t figure out how to use it’s remote in OSMC installed on my RPi 3.
I think that CEC is working (it will switch source to OSMC when I reboot RPi 3 and also turn the TV off if I set it up ), but remote does not work.

There is “Universal Remote” setting in the TV, but if I try to use it I have to select type of device (possible options are Blu-ray player, set-top box, home cinema system or game console) and after that I have to select it’s manufacturer (and RPi 3 or OSMC are not present there). First I tried it without configuring the TV or OSMC (expecting plug and play) and it didn’t worked then I tried to set it as Apple TV and then selected Apple TV remote in My OSMC on RPi 3, but it didn’t help.

Does anybody here have Series 7 Samsung TV and can help me configure my TV/OSMC please?

It’s this TV:
And this remote:


This looks like it may help:

Thanks Tom.

1 Like

Thank you for your suggestion @Tom_Doyle. Unfortunately, that didn’t help either.
I’ve read somewhere, that it could be caused by bad HDMI cable. I’ve ordered a new one and also borrowed one from work.

I’ll report back if any of those cables resolves my issue.

Turns out my original cable was bad. With the new cable, all works automagically.


Glad to hear its sorted.

Thanks Tom.