Sandisk Ultra 64gb micro sd XC I wort load

i just got the Raspberry Pi 2 b
i grabbed my Sandisk Ultra 64gb micro sd XC I formated it to exFat, then i loaded the installer and installed the osmc.
as you can see i did not know about the fat32 only.
this has caused a big issue with my card.
it starts to load and then gives me an error.
i then tried to format the card to fat32 to fix the issue.
guess what it wont format.
so i search the internet.
i cant format it.
i need help, can someone help?
i have tried,

  • diskpart
  • sd formater
  • gpart
  • hp usb fomater
  • linix terminal to format
  • im sure i have missed a few.

it either says that it is read only, that it just wont format or that its locked.
it doesnt have a lock switch so i know thats not it.
thanks guys

If using an sd card adapter make sure the sliding lock on the side is forward or pushed towards the connector prongs. Sometimes they get pushed back putting it into read only mode when you insert them into the computer. I use gparted. Open gparted, bring up the correct disk, on linux mine is always sdb and my harddrive is sda but this can change. Then with gparted unmount the drive, delete each partition, right click the empty drive, click new, select fat32 and make sure you hit the enter button on the toolbar or else it wont delete the card or re format it. after you are done just double check to make sure you have 1 partition and it is fat32

Ok a card without a lock switch reporting read only might be an indication that it’s gone.
Anyhow let’s start from the beginning.
Which OS are you using?
Does the card reader maybe have a lock switch?
What is the output of fdisk -l when the card is plugged in?

Just as a remark for your next adventure, you don’t format the card and put the file on. You either write an image to the card (with dd) or easier you run the osmc installer on your PC which does the job for you.

I don’t think a 64GB SDXC card is compatible with Raspberry Pi

I’ve seen lists out there where people posted their results with different sd cards. Nice tabled lists. Everyone loves sandisk and think because of the name it should be fine. Ive never had problems with samsung evo cards and they are faster than the one you have and cheaper than a sandisk of equal speed. I’ve had issues with sandisk before.

I’m using a SanDisk Ultra 64GB microSD w/ Pi just fine, albeit it’s Pi 3 and not Pi 2 b.

Provided the Pi 2 b doesn’t have compatibility issues, are you just trying to load OSMC onto it? If so, maybe bypass the manual formatting attempts altogether and just try and use Win32 Disk Imager and an OSMC image. Maybe Win32 DI will flash it properly where your manual methods have failed?

I’m using a “Sundisk microSDXC Ultra 64GB, Class 10, UHS-I, 48MB/Sec” with an Pi 2 b without any problem since May 2015.

hello, thanks for getting back to me so quick.
i will try to answer the best i adapter doesnt have a lock on it.
i have tried on windows, mac android phone and tablet and ubuntu to format.
i tried all there normal ways and any formatting or partition ways that they have with no luck.
gpart says failed every time.
the fdisk -l sees the disk for the full 64gb but wont let me clean, format, partition or any other option other forums and posted.
i did use the osmc installer, it did its formatting and added the files and the partition but according to a forum i read it said that if you pre format anything higher then 32bg with a exfat it will fail to work (which i can say is true)
i have tried the win32 disk format and it did not work.
right now i just need to figure out how to format it.
so i guess my main question is other then what i have already said i have used… the almighty hail mary for formating…
does any one have any other ideas on ways to format the SD?

You could try to create two partitions with 32GB each with gparted. Then delete both and reformat the free space to 64GB fat32.

Edit: Also a log from gparted would probably be helpful.

Try FAT32 formatter.

I use a Sandisk Ultra 64gb SD card on my Raspberry Pi. You just need to use a third-party FAT32 formatter to format it.

All 64GB and larger SD cards are SDXC cards.

You are probably trying to use an SDXC card in an older SDHC SD card reader. This will not work.

Make sure your SD card reader/slot specifically says SDXC compatible. If not buy an SDXC USB SD card reader and use this to prepare the SD card with the OSMC image.

Symptoms of trying to use an SDXC card in an SDHC reader slot include the card only appearing to be 1MB in size, or being “read only”. Trying to write to the card using an incompatible reader will corrupt it however it will be ok after reformatting with an SDXC reader.

The Raspberry Pi definitely supports 64GB SDXC cards - I use one myself in my Pi 2 but I had to buy a USB SDXC reader as my laptops SD slot and the older USB reader I had were both not SDXC compatible and thus unable to prepare the card.