Scheduling Flexget to run every hour using systemd timers

I have Transmission and Flexget working together nicely and would like to set up Flexget to execute every hour. The Flexget manual page suggests that it should be possible to set this up using systemd timers:

Using systemd/timers

If your system is running with systemd you can directly configure it to run the command every hours as the current user with the following command:

systemd-run --on-active="1h" --uid=`id -u` --gid=`id -g` `which flexget` execute

This will prompt you for the root password (as system services require root to be configured) and then will let you know the name of the service. You can confirm it was scheduled by looking at the system.d scheduler with systemctl list-timers .

However, when I try this command myself (as an ordinary user and as root), the entries that are added to the list of tasks don’t look right:

Fri 2019-05-17 15:17:10 CEST 58min left n/a n/a run-u47.timer run-u47.service
Fri 2019-05-17 15:18:42 CEST 59min left n/a n/a run-re4290d2b1a584b1091cf0541e8d54821.timer run-re4290d2b1a584b1091cf0541e8d54821.service

Could anyone advise me on how I can set this up properly? Or are Cronjobs the preferred way to do this? Thank you.

Another option is to run flexget as a systemd system unit service (Daemon):

Then use the flexget scheduler plugin to execute your tasks according to your scheduling preferences: