Screen blackout after bootup

I started getting a black screen after bootup a couple of hours ago. Here is a detailed description. Log is at the end.

The issue: Black Screen after Bootup. No accress to OSMC GUI. I did notice that during startup a couple of processes had “[FAILED]” at the beginning of the line.

What was I doing when this issue occurred? Booting up.

Can I replicate this issue on demand? No.

The device I am currently running OSMC on: Raspberry Pi 3.

Peripherals: Micro SDHC (Samsung), Nano USB Stick (Sandisk), HifiBerry DAC+, TV
Power specs: 5V, 2a
Video Output: HDMI
Audio Output: HDMI, RCA

Has this issue been introduced by a new version of OSMC? Not to my knowledge. I did upgrade OSMC after first install (2 days ago), but encountered no issues right after that. Installed a couple of addons, but they seemed to function Ok. I am not sure how can I disable them now, if needed.

When did the issue first appear and can I recall a time when it was not present? Not present upon completing installation. Showed up about a day after installation.


Help is very much appreciated.

08:24:31 10.498759 T:1956733872 DEBUG: EGL initial desktop resolution 640x480 (640x480) @ 60.00 - Full Screen (1.00)

Your Pi is booting up in 640x480, which usually happens if it cannot read the EDID from the TV to tell it what modes are available.

This could be for a number of reasons:

  1. The Pi was booted before the TV was powered on - make sure the TV is on first before powering on the Pi. (Although there is a workaround if this is not practical)

  2. Faulty or not properly connected HDMI cable - try a different cable.

  3. TV not sending an EDID - try powering the TV completely off at the wall for a few minutes then turn it back on, then reboot the Pi.

I also notice you have hdmi_force_hotplug=1 in your config.txt - this is not a default setting, did you add this manually, if so why do you think you needed it ? This is normally only used to work around problems with HDMI implementations in TV’s or in conjunction with the option to use a custom edid file.

Thank you DBMandrake.

You are correct. I did turn my Pi on without powering on the TV.
I had no idea this is a no-no. Did that for Pi “housekeeping” purposes.

As per your suggestions:

  1. I would like to know of any workarounds to allow me to power up the Pi without TV on.
  2. The cable is fine. I have other OSs installed, they are projected on my TV without problem.
  3. Tried unplugging the TV from power and then powered back on. Rebooted Pi after that.
    Pi still loads up in 640x480.
    Is there a way to force other resolutions on Pi? Is this advisable at all? I have no intention to connect any other screen to the Pi in the near future.

So… I am still in the darkness.
I’ll appreciate more comments about this issue.

hdmi_force_hotplug=1 was not edited by me.
Should I reset it? to what? (how? nano config.txt? what folder?)

If you boot the pi AFTER completely powering on the TV, do things work as expected? If yes, then simply do this

No, things do not work as expected.
In fact, only now did I notice that the other OS (Raspbian) on this Pi boots up in 640x480, which is not normal.
I saw that only now, because I access the Raspbian environment headless most of the time.

I have tried the complete power-off and reboot a couple of time to no avail. Still getting 640x480 on boot (on both OSMC and Raspbian now).

ActionA- what you sent is interesting, although it may not correspond 100% with my issue.
I noticed however that this link suggests to add “hdmi_force_hotplug=1” to config.txt (among other things), which is something that DBMandrake has asked me about. Apparently it already exists in my machine without my intention.
Could that be the problem??
Is it possible this setting has “locked” my Pi on the wrong resolution?

Try a different HDMI cable. You current cable may have failed.

Tried numerous workarounds with no luck so far.
I changed HDMI cables, and fiddled with almost every possible setting in config.txt.
Tried forcing lots of hdmi_group and hdmi_mode combinations that should have worked with my TV, and also some that shouldn’t. Results were all the same: black screen.
I also checked the etc/fstab setting as I saw some users had problems with boot partitions. Mine looks just fine (BTW, I am on a Noobs installation with dual boot here). At some point I thought my Hifiberry card could be the problem, but wasn’t able to find any mention of possible problems with that.
Added edid file (with the current HDMI cable attached) and placed in the boot directory.
Also tried Hard and Soft-resetting my TV set.

What really bugs me is that I was able to use OSMC for a couple of days. Things have gone bad out of the blue.
My hardware is pretty much ordinary (rPi 3, Panasonic Plasma TV).
I’d appreciate additional thoughts on my situation.