Screensaver not going black when video is paused (yes option is deactivated)

#1

Hi guys some bug:

Its easy to reproduce

  • Go to settings -> desktop
  • Change the screensaver to black
  • Waittime to one minute
  • Uncheck the option “Dimming if the video is paused”
  • Start a video over Network or usb -> pause the video and wait a minute
  • Screen is dimming down to 20 % and not going to black

So the option is not working? I need the black screen option because i have an OLED and want to save energy and prevent burn in when iam pause the movie to get on the phone or the door. Whats really strange the same thing happens with Libreelec but it seems only on ARM versions because if i’am tested kodi 18.1 on my Windows PC it goes to black like it should. So somebody with a Raspberry Pi 3B+ could be test it and yes i rebooted the system mutiple times its not changing.

It’s 100 % a bug i tested it also with Libreelec and exact the same thing is happening it seems only working on Windows without that bug (atleast thats the only plattform i could test it except the Pi).

Hardware: Raspberry Pi 3B+ with the newest osmc version

Two workarounds i’ve made:

Method 1:

THIS CHANGE THE SYSTEMSETTINGS OF KODI AND CAN MAYBE CRASH IF YOU DO A UPDATE, SO
ONLY USE IT IF YOU KNOW WHAT ARE YOU DOING, IF NOT GO TO METHOD 2 WHICH IS SAVER.

Log in as “root” in Putty/Terminal/WinSCP etc.

Go to

/usr/share/kodi/addons/screensaver.xbmc.builtin.dim/resources/settings.xml

And change
range=“20,1,100”

to:
range=“0,1,100”

Then reboot, go to:
desktop -> Screensaver -> Select dim -> Settings -> change to 0 %
then you can let it in dimming mode OR use the black screensaver which
is now working (before the black screensaver did go to 20 % for no reason).

Method 2:

Log in as “root” in Putty/Terminal/WinSCP etc.

Type in (or copy the folder via WinSCP):

cp -a /usr/share/kodi/addons/screensaver.xbmc.builtin.dim /home/osmc/.kodi/addons/

Then edit the settings file in

/home/osmc/.kodi/addons/screensaver.xbmc.builtin.dim/resources/settings.xml

change
range=“20,1,100”

to:
range=“0,1,100”

Then reboot then go to:
desktop -> Screensaver -> Select dim -> Settings -> change to 0 %
then you can let it in dimming mode OR use the black screensaver which
is now working (before the black screensaver did go to 20 % for no reason).

It would be nice if @sam_nazarko or maybe some Kodi Dev can fix the bug? Because with that Bug the Black Screensaver is useless.

#2

If this also occurs on LE I would suggest reporting this issue upstream

Sam

#4

How can i do that? Sorry not really into all of this stuff :smiley: would be nice if you can show me what i must do :slight_smile:

#5

Kodi bugs can be reported here:

#6

Thank you :slight_smile:

#7

Done guys thank you very much i hope they can fix it :slight_smile:

#8

I would suggest making it clear that it can be produced on both LE and OSMC (likely any GLES platform); so that it is not considered an OSMC only issue.

Sam

#9

Oh you are right let me added it.

Edit: Added :slight_smile:

#10

Doesn’t happen on Vero for me.

#11

Interesting is the code for Vero and Pi different?