Sd-card failing form time to time

my sd-card is failing from time to time with the following error:

**mmcblk0: timed out sending r/w cmd command, card status 0x400e00**

the card is high quality (philips), brand new and ext-4 formatted. after a reboot it’s being mounted correctly again and everything works as expected. i did not configure fstab since osmc mounted it automatically in /media/data.
how does osmc mount removable media? would you suggest to make an automount for it?


The error will not be mitigated by using a different mounting technique.

Some full logs when this happens might help


last time the disc failed was this morning around 10.00. hope the logs contain the incident …

only information i could find is:

 20.678879] EXT4-fs (mmcblk0p1): recovery complete
[   20.678903] checked enable EXT4 DISCARD here
[   20.678910] EXT4-fs (mmcblk0p1): mounting with "discard" option, but the device does not support discard
[   20.678918] EXT4-fs (mmcblk0p1): mounted filesystem with ordered data mode. Opts: data=ordered

Does removing the card and reinserting it solve the problem?

Is it a full sized card or a micro SD in an adapter?

reinserting sometimes seem to solve the issue.

its a microsd in an adapter

I would suggest trying another adapter.

ok, actually i am using the original adapter by philips that came with the card, but i can try to use another one by sandisk. does the vero 2 have micro-sd-slot?

It does not. We switched to microSD in the Vero 4K.

i tried another adapter (different brand), same behaviour.
my fstab entry looks like this:
/dev/mmcblk0p1 /media/data ext4 rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks

other ideas for troubleshooting?

Perhaps the card is failing.

Did you check it with h2wtest?

i don’t think so, card was freshly formatted (iam not on windows, is there an alternative to h2wtest for debian?). once in a while i am not able to “ls” the mountpoint anymore, in that case only a reboot helps. after reboot everything works as expected again …

thanx for the hint! i tested it and as expected no errors:

osmc@B2VERO:~$ f3write /media/data/
Free space: 14.56 GB
Creating file 1.h2w … OK!
Creating file 2.h2w … OK!
Creating file 3.h2w … OK!
Creating file 4.h2w … OK!
Creating file 5.h2w … OK!
Creating file 6.h2w … OK!
Creating file 7.h2w … OK!
Creating file 8.h2w … OK!
Creating file 9.h2w … OK!
Creating file 10.h2w … OK!
Creating file 11.h2w … OK!
Creating file 12.h2w … OK!
Creating file 13.h2w … OK!
Creating file 14.h2w … OK!
Free space: 1.46 GB
Average writing speed: 6.74 MB/s
osmc@B2VERO:~$ f3read /media/data/
SECTORS ok/corrupted/changed/overwritten
Validating file 1.h2w … 2097152/ 0/ 0/ 0
Validating file 2.h2w … 2097152/ 0/ 0/ 0
Validating file 3.h2w … 2097152/ 0/ 0/ 0
Validating file 4.h2w … 2097152/ 0/ 0/ 0
Validating file 5.h2w … 2097152/ 0/ 0/ 0
Validating file 6.h2w … 2097152/ 0/ 0/ 0
Validating file 7.h2w … 2097152/ 0/ 0/ 0
Validating file 8.h2w … 2097152/ 0/ 0/ 0
Validating file 9.h2w … 2097152/ 0/ 0/ 0
Validating file 10.h2w … 2097152/ 0/ 0/ 0
Validating file 11.h2w … 2097152/ 0/ 0/ 0
Validating file 12.h2w … 2097152/ 0/ 0/ 0
Validating file 13.h2w … 2097152/ 0/ 0/ 0
Validating file 14.h2w … 197352/ 0/ 0/ 0

Data OK: 13.09 GB (27460328 sectors)
Data LOST: 0.00 Byte (0 sectors)
Corrupted: 0.00 Byte (0 sectors)
Slightly changed: 0.00 Byte (0 sectors)
Overwritten: 0.00 Byte (0 sectors)
Average reading speed: 12.93 MB/s

as expland above, sd-card and adapter are brandnew. i strongly suspect the system is failing here somehow …

i am running a postgress database on that sd-card (because internal storage is too small for it). could it have to do something with how postgress is reading or writing data on external drives?

I wouldn’t recommend running a database off an SD card personally.
When it happens again, does removing and reinserting the card help?

i know, that this is not the optimal, sadly internal storage is just too small on the vero.
if i remove and reinsert the card it is not automounted, sometimes the device freezes when i do that after it failed.

The database should be relatively small compared to your thumbnail folder and that would be a much less wearing for flash storage than a database. I would move your thumbnails folder over to the SD card and path substitute in advancedsettings.xml to point to the new location. This should give you more than enough room to move your db to internal storage. This will also provide the extra benefit that if the SD dumps again you don’t have to rebuild anything as the thumbnail folder will automaticly repopulate itself.

the kodi thumbnail folder is already on the sd-card. i am running postgress for another reason on the device (kodi does not support postgress to my knowledge). so is it correct, that the vero sd-card-slot is not reliable enough to run permanent linux-services on it and could this be the reason for the failing of the card?

SD cards themselves are not great candidates for any kind of database or reliable storage. You could see if you have better luck with USB connected storage, but if your thumbnails are not taking up any room on the eMMC what is using all the storage space?

Are you sure about that? I don’t see where you added a path substitution in your advancedsettings.xml file.

i am using postgres together with a communication software that runs on my personal mobile devices. it was working perfectly as long as the database was not too large and i still was able to keep it in internal storage.

You could see if you have better luck with USB connected storage […]

Is that just something i could try or is it in general more likely that USB-sticks are more reliable on Vero?

Are you sure about that? I don’t see where you added a path substitution in your advancedsettings.xml file.

Yes i am, i solved it with a symlink from osmc/thumbnails to external storage (had no issues with this solution so far).

Generally speaking, not related to the Vero, SD cards are among the least reliable storage mediums. Thumb drives can vary greatly in how they are made and how reliable they are, but in general, they are usually a step up from an SD card. A USB connected SSD or spinning rust would be much better options for a durability standpoint though.

As for the SD reader in the Vero itself I have no clue. I know the microSD to SD adapters can be flakey even when brand new, and SD slots can get bad connections over time. I’ve seen it a lot in PC’s including my own. Personally I have much better luck using a USB microSD reader than the passive adapters on my PC’s.