SD Card not showing correct in GParted

I copied a packup of my SD Card of Raspberry Pi and restored it on a larger SD Card. Now i want to extend the filesystem in GParted but GParted cant show the partitions of the SD Card, it says no partition tables found.
Screen:
https://www.pic-upload.de/view-33419682/Screenshot_20170628_233046.png.html

thanks.

Hi,

Does bigger sd card boot up in to osmc? I just wonder as the image may not have restored correctly.

You may be better to backup your configuration via my osmc and doing a new install to the bigger sd card, then restore the settings backup.

Thanks Tom.

Or backed up correctly.
I think you may have backed up a volume rather than the entire block device.

The Backup on the new SD Card works fine and Boot normaly.

very odd. What does fdisk -l /dev/mmcblk0 show?

and you might like to try my restore/clone script here

sudo ./osmc-restore -f / will format the new card and copy both partitions over.

fdisk shows:
Medium /dev/mmcblk0: 29,8 GiB, 32010928128 Bytes, 62521344 Sektoren
Einheiten: sectors von 1 * 512 = 512 Bytes
Sektorengröße (logisch/physisch): 512 Bytes / 512 Bytes
I/O Größe (minimal/optimal): 512 Bytes / 512 Bytes

I think your restore has not written the partition table correctly, but somehow there is enough information for OSMC to find its system partition and boot. I suggest you try the backup again (I assume you are using dd) or try copying the files with the osmc-restore I linked to.

I’m a bit puzzled about what device you are running gparted on. If on a Pi running Raspbian or some other linux, the target sd card would normally be /dev/sda or so, not /dev/mmcblk0.

Here’s what a 32GB SD card should look like:

osmc@osmc:~$ fdisk -l /dev/mmcblk0

Disk /dev/mmcblk0: 29.8 GiB, 32010928128 bytes, 62521344 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa0d13c40

Device         Boot  Start      End  Sectors  Size Id Type
/dev/mmcblk0p1        2048   499711   497664  243M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      501760 62521343 62019584 29.6G 83 Linux

Could you describe exactly how you backed up and then restored the data?

The SD card could not be read by my Linux Mint system so i had to use Windows and Win32Diskimage to backup the SD card. After the backup i used Win32Diskimage to restore the backup to my new SD card. I also tried to mount the SD card on a Lubuntu live system but there it also cant be mounted. So the problem must be on the OSMC installation!?
I formated the original SD card so i cant do a backup again :frowning:
If i install OSM completely new on the new SD card and use the MyOSMC backup and restore function will it be as before?
Thanks

The situation is a bit odd but if it’s still somehow working, you should be able to backup your configuration before performing a reinstall. But before you go down that path, could you run grab-logs -A so that we can get a better idea of its current state?

Here the log:
https://paste.osmc.tv/hajohazege

The logs show a working system, and you still have a lot of free space on the root partition:

Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
devtmpfs        330M       0  330M    0% /dev
tmpfs           335M    4,7M  330M    2% /run
/dev/mmcblk0p2   15G    9,6G  3,8G   72% /
tmpfs           335M       0  335M    0% /dev/shm
tmpfs           5,0M       0  5,0M    0% /run/lock
tmpfs           335M       0  335M    0% /sys/fs/cgroup
/dev/mmcblk0p1  240M     22M  218M   10% /boot
/dev/mmcblk0p3   16G     32K   16G    1% /media/VOLUME
/dev/sda1       3,7T    3,6T   95G   98% /media/My Book
tmpfs            67M       0   67M    0% /run/user/1000

It looks like there was some kind of issue with the original partition table that the backup/restore probably copied across to the new card but fortunately it’s not stopping the system from booting. The remaining space on the card is being mounted as /media/VOLUME, but I’d guess it’s not currently formatted.

At some point, you’ll probably want to backup everything and reinstall OSMC but there doesn’t seem to be urgent need to do so right now.

Probably, you are right, but you do seem to have a workable install, still.

But you do seem to have a good clone of the original, including a clone of its faults! I can’t immediately see anything suggesting the file system is corrupt - it just seems to be the partition metadata that’s wrong.

OSMC backup only backs up the kodi settings. You have some other stuff on there. What I would do, IMHO is:

connect a (ext formatted) usb disc to the Pi and use osmc-backup from the link to copy the files across to the usb

sudo systemctl stop mediacenter sudo ./osmc-backup /media/usbdiscname/backupdir

copy the contents of your mmcblk0p3 partition (/media/VOLUME) to the usb disc as well

cp -a /media/VOLUME /media/usbdiscname/backupdir2 Edit: I see it’s got nothing on it, so miss that step.

reformat the SD card in Windoze with the SDformatter from the SD card Association and make sure it mounts on your linux mint machine

restore the backup you made with osmc-backup using osmc-restore from your linux mint machine to the card

sudo osmc-restore -f /media/yourusername/usbdiscname/backupdir, picking the SD card device name from the list which appears. This will fill the card, so you then have to decide what to do with the contents of backupdir2.

Insert card in Pi and boot up. If you are nervous and have another spare card, of 16G or bigger, try the restore on that first.

If i try the backup script i get the following message:
osmc@OSMC:~/osmc-backup-master$ sudo ./osmc-backup /media/My\ Book/backup
./osmc-backup: Zeile 61: [: /media/My: Zweistelliger (binärer) Operator erwartet.
Do 29. Jun 22:50:37 CEST 2017 Backup version 0.1.6
Going to back up to /media/My Book/backup/2017-06-29 (unless I can’t find it).
looking for mounted media
media for /media/My Book/backup not mounted in /media or /mnt or not formatted for linux

Let me check - could be the space in My Book that’s bothering it.

Oh, I see My Book is not ext formatted - it’s ntfs. So your file permissions and ownerships would not be preserved. Can you find an ext3/4 disc or maybe share a disc from your linux mint machine via nfs?

Edit: updated both scripts so backup paths with spaces are handled. Thanks for testing!

So finally i reinstalled osmc and restored a backup.
For some reason my linux system has trouble wit the new Samsung SD Card, it cant format the card correctly :confused:. And the Backup/Restore script i tried had also some problems, maybe because of the SD Card :frowning:.
So i decided to reinstall osmc, i think all problems were caused by the brand new SD Card?!
But thanks for your help :slight_smile:

Just in case anyone else is in the same situation: your original card was 32G, so your new card is 64G or bigger. Makes me wonder whether writing an image taken from a SDHC card and writing it to a SDXC card just doesn’t work, or perhaps your linux mint machine doesn’t support SDXC?

Hi, my Laptop runs both Windows 10 and Linux Mint. So it can’t be the SD Card Support of the Laptop :confused: . My previous SDHC Card was a 16gb Adata and my new is a SDXC 32gb Samsung .

Though the hardware is the same, each operating system will have different drivers.

You didn’t say which type of Samsung SD card, but my experience of Samsung EVO cards has been positive. Adata, much less so.

So how did you manage to create the partition which got mounted at /media/VOLUME (/dev/mmcblkop3) if you couldn’t get gparted to work?