Second USB Movie Source USB on Pi

My OSMC/KODI setup is on a Raspberry Pi V3. The media are stored on a 1TB SSD using a USB adapter cable. Working GREAT!!!

The other day I encoded some new films on to a 16GB USB memory stick. I thought I could just plug it into an empty USB port on my Pi and then via the Video/Files/… sequence be able to preview the new content without actually adding it to the system.

That worked and I was able to view the content on the USB stick. HOWEVER, when I tried to view some historical content from the SSD, I got a message that that content was no longer available. After rebooting without the USB stick, all historical content again was available, whew…

So, my question is "Is there a way to have both the historical content coming from the USB 1TB SSD drive and ALSO be able to preview content on another source, ie not on the 1TB SSD?


Sure, you could try a powered USB hub or another power supply for the Pi. Most possible the power consumption of both devices is exhausting the Pi’s power supply.

Most SSDs have the power specification (Volt/Ampere) documented on the label on the device.

Hmmm, I did not think of that. I assumed it was being confused by two USB devices.

I’ll repeat and via SSH see if it sees the two devices. Thanks for the idea…RDK

OK, I did the experiment(s) and

  1. with both plugged in, it only see the USB stick.
  2. the /ect/fstab file only has one entry, sda1. So I added another for sdb1. Now it sees both but KODI still seems using the sda1 connection, which continues to point to the USB stick, for its historical data/films.

How can I force sda1 to point to the SSD and sdb1 to the USB Stick? I’m reluctant to use UUID or PARTUUID in the fstab. I had a bad experience which forced a total rebuild of a Pi when the target USB drive had a memory failure and wiped out it PARTUUID which caused the Pi to not boot up.


None of this should be necessary. You are still yet to be addressing the fact that use of both USB devices requires more power than the Pi can provide.

Experiment 2 in my previous reply shows that the Pi sees both USB devices and I listed the content of each and they were complete. Thus, it would seem to me that POWER is not the issue. The issue seems to be the order that the Pi is attaching the devices. The USB stick seems to be preferentially assigned to sda1.

My next experiment will be to use the UUID in the fstab file, but that will have to wait until I again have access to the Pi…RDK

OK, I used the UUID format for the SSD drive in the fstab file. It worked and I now have it assigned as the medialib drive in KODI and the USB stick defaults and is assigned to sda1.

I can play media from either now, so it was not a power issue.

I’m still not happy using the UUID format and will probably revert to the old format for general usage and activate the UUID format when I want to get content from a USB stick.


Well UUID is the right way in 2021 to mount devices as device referrer (sdXX) will change depending on many factors.
But the main point here is that you don’t need any fstab entries as normally OSMC automatically mounts any device based on it’s filesystem label. So as long as you use proper labels that should be good enough.

Thanks. Yes, I guess I have observed that the “device referrer” system is not reliable when adding or removing disks.

Can you better define what you mean by " filesystem label" and how KODI used them?..RDK

Well when you format your drive you give it a filesystem and that filesystem you give it a label.
This is not related to Kodi but to OSMC. OSMC has an automounter that will mount every device automatically under /media/<device label>
So from Kodi you can include it in the library by choosing /media/<device label> as the location

Cool. Thanks, I was not aware of this. Thanks…RDK